aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorZhixiong Chi <zhixiong.chi@windriver.com>2018-08-13 00:04:23 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-08-14 11:36:22 +0100
commit49f979b13f1bc6ece0f343d41421aba43f8d9e21 (patch)
tree25c90e786ba015b423c96b2a9f1cd54505164e7e /meta/recipes-support
parent41688279cba3a5afc4fdc65fd245b9bb6ada695e (diff)
downloadopenembedded-core-contrib-49f979b13f1bc6ece0f343d41421aba43f8d9e21.tar.gz
libevent: fix the multilib header conflict
Error: Transaction check error: file /usr/include/event2/event-config.h conflicts between attempted installs of libevent-dev-2.1.8-r0.skylake_64 and lib32-libevent-dev-2.1.8-r0.x86 The conflict is the size macro definition between 32bit and 64bit such as: < #define EVENT__SIZEOF_LONG 8 > #define EVENT__SIZEOF_LONG 4 < #define EVENT__SIZEOF_PTHREAD_T 8 > #define EVENT__SIZEOF_PTHREAD_T 4 Signed-off-by: Zhixiong Chi <zhixiong.chi@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/libevent/libevent_2.1.8.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-support/libevent/libevent_2.1.8.bb b/meta/recipes-support/libevent/libevent_2.1.8.bb
index 83ce4644cf..0f91e05a6c 100644
--- a/meta/recipes-support/libevent/libevent_2.1.8.bb
+++ b/meta/recipes-support/libevent/libevent_2.1.8.bb
@@ -28,12 +28,16 @@ inherit autotools
# Needed for Debian packaging
LEAD_SONAME = "libevent-2.1.so"
-inherit ptest
+inherit ptest multilib_header
DEPENDS = "zlib"
BBCLASSEXTEND = "native nativesdk"
+do_install_append() {
+ oe_multilib_header event2/event-config.h
+}
+
do_install_ptest() {
install -d ${D}${PTEST_PATH}/test
for file in ${B}/test/.libs/regress ${B}/test/.libs/test*