aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorLei Maohui <leimaohui@cn.fujitsu.com>2018-06-10 15:23:35 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-06-27 13:53:28 +0100
commit2d9a8a5539342faa1827f4902b1095a9f3448c66 (patch)
tree5d77f52230f082b5ea43c8f6c5a7e9fb4a33a024 /meta/recipes-support
parentb2cd021887e12d9f5b8ba48d9be3c2f2119c8e2a (diff)
downloadopenembedded-core-contrib-2d9a8a5539342faa1827f4902b1095a9f3448c66.tar.gz
nss: Fix build error for aarch64be.
Signed-off-by: Lei Maohui <leimaohui@cn.fujitsu.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/nss/nss_3.36.1.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-support/nss/nss_3.36.1.bb b/meta/recipes-support/nss/nss_3.36.1.bb
index f8555389ff..780a7ab088 100644
--- a/meta/recipes-support/nss/nss_3.36.1.bb
+++ b/meta/recipes-support/nss/nss_3.36.1.bb
@@ -89,6 +89,8 @@ do_compile() {
OS_TEST=ppc64
elif [ "${TARGET_ARCH}" = "mips" -o "${TARGET_ARCH}" = "mipsel" -o "${TARGET_ARCH}" = "mips64" -o "${TARGET_ARCH}" = "mips64el" ]; then
OS_TEST=mips
+ elif [ "${TARGET_ARCH}" = "aarch64_be" ]; then
+ OS_TEST="aarch64"
else
OS_TEST="${TARGET_ARCH}"
fi
@@ -144,6 +146,9 @@ do_install() {
OS_TEST=ppc64
elif [ "${TARGET_ARCH}" = "mips" -o "${TARGET_ARCH}" = "mipsel" -o "${TARGET_ARCH}" = "mips64" -o "${TARGET_ARCH}" = "mips64el" ]; then
OS_TEST=mips
+ elif [ "${TARGET_ARCH}" = "aarch64_be" ]; then
+ CPU_ARCH=aarch64
+ OS_TEST="aarch64"
else
OS_TEST="${TARGET_ARCH}"
fi