summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-04-06 10:10:47 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-04-12 17:26:40 +0100
commitc3568ee00d3b7f6b421020dfec8005a27c2e9164 (patch)
tree5c6f45b529e600d21e5ced6587cb1b3a7be0d5bb /meta/recipes-support
parentd027236eac2a136b06903d4a47adbc50ccd6b7c6 (diff)
downloadopenembedded-core-contrib-c3568ee00d3b7f6b421020dfec8005a27c2e9164.tar.gz
libseccomp: Fix build when python packageconfig is enabled
It needs additional tweaks with python enabled Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/libseccomp/libseccomp_2.5.5.bb10
1 files changed, 8 insertions, 2 deletions
diff --git a/meta/recipes-support/libseccomp/libseccomp_2.5.5.bb b/meta/recipes-support/libseccomp/libseccomp_2.5.5.bb
index 06ba5e9c98..478e5f4289 100644
--- a/meta/recipes-support/libseccomp/libseccomp_2.5.5.bb
+++ b/meta/recipes-support/libseccomp/libseccomp_2.5.5.bb
@@ -17,10 +17,12 @@ S = "${WORKDIR}/git"
inherit autotools-brokensep pkgconfig ptest features_check
+inherit_defer ${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3native', '', d)}
+
REQUIRED_DISTRO_FEATURES = "seccomp"
PACKAGECONFIG ??= ""
-PACKAGECONFIG[python] = "--enable-python, --disable-python, python3"
+PACKAGECONFIG[python] = "--enable-python, --disable-python, python3-cython-native"
DISABLE_STATIC = ""
@@ -48,9 +50,13 @@ do_install_ptest() {
for file in $(find tools/.libs/* -executable -type f); do
install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tools
done
+ # fix python shebang
+ sed -i -e 's@cmd /usr/bin/env python @cmd /usr/bin/env python3 @' ${D}/${PTEST_PATH}/tests/regression
+ sed -i -e 's@^#!/usr/bin/env python$@#!/usr/bin/env python3@' ${D}/${PTEST_PATH}/tests/*.py
}
-FILES:${PN} = "${bindir} ${libdir}/${BPN}.so*"
+FILES:${PN} = "${bindir} ${libdir}/${BPN}.so* ${PYTHON_SITEPACKAGES_DIR}/"
FILES:${PN}-dbg += "${libdir}/${PN}/tests/.debug/* ${libdir}/${PN}/tools/.debug"
+RDEPENDS:${PN} += "${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3', '', d)}"
RDEPENDS:${PN}-ptest = "coreutils bash"