aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-11-02 17:45:46 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-11-06 23:35:36 +0000
commit98417f180537affbdc7b32e51ebd96a780a86024 (patch)
tree9d90b8316e7851f50da6e8224d8ddebe900f1d22 /meta/recipes-support
parent681d81177666314d7742654ac9537b34b39cd5b6 (diff)
downloadopenembedded-core-contrib-98417f180537affbdc7b32e51ebd96a780a86024.tar.gz
db: remove pointless documentation
db-doc has an installed footprint of 94MB, but 60MB of that is the documentation for the Java and C# bindings which are not part of this recipe. Remove them and the for-print PDF manuals to massively reduce the footprint of db-doc. Also improve the fix for the documentation install path, and put the documentation under ${docdir}/db instead of just ${docdir} (which is /usr/share/doc by default). (From OE-Core rev: 89e9d8fc7f99fb6346dc035e51abbc942011d9b5) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/db/db_6.0.35.bb14
1 files changed, 6 insertions, 8 deletions
diff --git a/meta/recipes-support/db/db_6.0.35.bb b/meta/recipes-support/db/db_6.0.35.bb
index 32afbe82d8..f60edf9566 100644
--- a/meta/recipes-support/db/db_6.0.35.bb
+++ b/meta/recipes-support/db/db_6.0.35.bb
@@ -87,7 +87,7 @@ MUTEX_arm = "${ARM_MUTEX}"
MUTEX_armeb = "${ARM_MUTEX}"
EXTRA_OECONF += "${MUTEX}"
EXTRA_OEMAKE_append_class-target = " LIBTOOL=${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool"
-EXTRA_OEMAKE += "STRIP=true"
+EXTRA_OEMAKE += "STRIP=true docdir=${docdir}/db/"
do_compile_prepend() {
# Stop libtool adding RPATHs
@@ -101,14 +101,12 @@ do_install_append() {
ln -s db60/db.h ${D}/${includedir}/db.h
ln -s db60/db_cxx.h ${D}/${includedir}/db_cxx.h
- # The docs end up in /usr/docs - not right.
- if test -d "${D}/${prefix}/docs"
- then
- mkdir -p "${D}/${datadir}"
- test ! -d "${D}/${docdir}" || rm -rf "${D}/${docdir}"
- mv "${D}/${prefix}/docs" "${D}/${docdir}"
- fi
+ # Prune the documentation to remove large (PDF) or pointless (Java) files.
+ find ${D}${docdir} -name *.pdf -delete
+ rm -rf ${D}${docdir}/db/java
+ rm -rf ${D}${docdir}/db/csharp
+ # The makefiles use cp -p, so we need to chmod until that is fixed.
chown -R root:root ${D}
}