aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-07-15 03:03:25 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-07-20 10:24:54 +0100
commit119ff60101ed6fd542f1280d37a24411d8b14264 (patch)
tree38425efdae13e7e345d05b5276a0f1c366156457 /meta/recipes-support
parentdd11ab551f9bf1d8761d0430f19510a9caa53a12 (diff)
downloadopenembedded-core-contrib-119ff60101ed6fd542f1280d37a24411d8b14264.tar.gz
nss: Fix build on mips/clang
This issue is also reported here https://trac.macports.org/ticket/51709 Patch is also from same ticket Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/nss/nss/pqg.c-ULL_addend.patch23
-rw-r--r--meta/recipes-support/nss/nss_3.24.bb1
2 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-support/nss/nss/pqg.c-ULL_addend.patch b/meta/recipes-support/nss/nss/pqg.c-ULL_addend.patch
new file mode 100644
index 0000000000..9caaaeb955
--- /dev/null
+++ b/meta/recipes-support/nss/nss/pqg.c-ULL_addend.patch
@@ -0,0 +1,23 @@
+nss does not build on mips with clang because wrong types are used?
+
+pqg.c:339:16: error: comparison of constant 18446744073709551615 with expression of type 'unsigned long' is always true [-Werror,-Wtautological-constant-out-of-range-compare]
+ if (addend < MP_DIGIT_MAX) {
+ ~~~~~~ ^ ~~~~~~~~~~~~
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+Upstream-Status: Pending
+Index: nss-3.24/nss/lib/freebl/pqg.c
+===================================================================
+--- nss-3.24.orig/nss/lib/freebl/pqg.c
++++ nss-3.24/nss/lib/freebl/pqg.c
+@@ -322,8 +322,8 @@ generate_h_candidate(SECItem *hit, mp_in
+
+ static SECStatus
+ addToSeed(const SECItem * seed,
+- unsigned long addend,
+- int seedlen, /* g in 186-1 */
++ unsigned long long addend,
++ int seedlen, /* g in 186-1 */
+ SECItem * seedout)
+ {
+ mp_int s, sum, modulus, tmp;
diff --git a/meta/recipes-support/nss/nss_3.24.bb b/meta/recipes-support/nss/nss_3.24.bb
index caed7fa894..c7c9fab2af 100644
--- a/meta/recipes-support/nss/nss_3.24.bb
+++ b/meta/recipes-support/nss/nss_3.24.bb
@@ -21,6 +21,7 @@ SRC_URI = "\
file://nss-fix-incorrect-shebang-of-perl.patch \
file://nss-fix-nsinstall-build.patch \
file://disable-Wvarargs-with-clang.patch \
+ file://pqg.c-ULL_addend.patch \
file://nss.pc.in \
file://signlibs.sh \
"