aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/vte/vte_0.44.2.bb
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2016-08-22 15:23:11 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-08-23 17:44:18 +0100
commit68898cf20f70fc7e7f517111ea7c2b901859263e (patch)
treefae80eeca77f8cbefc6c0236306568614dad49d5 /meta/recipes-support/vte/vte_0.44.2.bb
parente82bdb1e5ddecb347a75098d53f4db2d0b5aa853 (diff)
downloadopenembedded-core-contrib-68898cf20f70fc7e7f517111ea7c2b901859263e.tar.gz
vte: Upgrade 0.44.1 -> 0.44.2
Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support/vte/vte_0.44.2.bb')
-rw-r--r--meta/recipes-support/vte/vte_0.44.2.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-support/vte/vte_0.44.2.bb b/meta/recipes-support/vte/vte_0.44.2.bb
new file mode 100644
index 0000000000..a1204a3c3b
--- /dev/null
+++ b/meta/recipes-support/vte/vte_0.44.2.bb
@@ -0,0 +1,28 @@
+SUMMARY = "Virtual terminal emulator GTK+ widget library"
+BUGTRACKER = "https://bugzilla.gnome.org/buglist.cgi?product=vte"
+LICENSE = "LGPLv2.1+"
+DEPENDS = "glib-2.0 gtk+3 intltool-native"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
+
+inherit gnomebase gtk-doc distro_features_check upstream-version-is-even vala gobject-introspection
+
+SRC_URI += "file://0001-Don-t-enable-stack-protection-by-default.patch"
+SRC_URI[archive.md5sum] = "eca8f8a9d9f9bb8e9d592d0acfeec015"
+SRC_URI[archive.sha256sum] = "a1ea594814bb136a3a9a6c7656b46240571f6a198825c1111007fe99194b0949"
+
+ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
+
+PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls"
+
+CFLAGS += "-D_GNU_SOURCE"
+
+# Enable vala only if gobject-introspection is enabled
+EXTRA_OECONF = "--enable-vala=auto --disable-test-application"
+
+# libtool adds "-nostdlib" when g++ is used. This breaks PIE builds.
+# Use libtool-cross (which has a hack to prevent that) instead.
+EXTRA_OEMAKE_class-target = "LIBTOOL=${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool"
+
+PACKAGES =+ "libvte"
+FILES_libvte = "${libdir}/*.so.*"