aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/vte/vte_0.28.2.bb
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2012-01-03 14:59:31 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-01-04 11:55:25 +0000
commite5def5f36619c8f78fbb82f106f1ab7aab607532 (patch)
treebe13fbaafec7dad17713e455683cfff26c0d030f /meta/recipes-support/vte/vte_0.28.2.bb
parentc02b9de25b405c81da0f7bebd07423e8cee14eb7 (diff)
downloadopenembedded-core-contrib-e5def5f36619c8f78fbb82f106f1ab7aab607532.tar.gz
openembedded-core-contrib-e5def5f36619c8f78fbb82f106f1ab7aab607532.tar.bz2
openembedded-core-contrib-e5def5f36619c8f78fbb82f106f1ab7aab607532.zip
vte: upgrade from 0.24.3 to 0.28.2
Added a patch to add introspection.m4 to avoid the following configure error: | src/Makefile.am:168: HAVE_INTROSPECTION does not appear in AM_CONDITIONAL | autoreconf: automake failed with exit status: 1 | ERROR: autoreconf execution failed. NOTE: package vte-0.28.2-r0: task do_configure: Failed This upgrade avoids configure issues with automake version 1.11.2 seen on the earlier version of vte: | src/Makefile.am:155: `pkglibdir' is not a legitimate directory for `PROGRAMS' | src/Makefile.am:156: `pkglibdir' is not a legitimate directory for `SCRIPTS' | src/Makefile.am:178: variable `interpret_SOURCES' is defined but no program or | src/Makefile.am:178: library has `interpret' as canonical name (possible typo) | src/Makefile.am:229: variable `slowcat_SOURCES' is defined but no program or | src/Makefile.am:229: library has `slowcat' as canonical name (possible typo) | src/Makefile.am:203: variable `interpret_LDADD' is defined but no program or | src/Makefile.am:203: library has `interpret' as canonical name (possible typo) | autoreconf: automake failed with exit status: 1 | ERROR: autoreconf execution failed. NOTE: package vte-0.24.3-r0: task do_configure: Failed Did not upgrade to the latest version 0.31.0. 0.28.2 is the last version supporting gtk+ 2. Next versions have dropped support for gtk+ 2, and they require gtk+ 3. It would be more appropriate to move to next version after gtk+ 3 recipe is available. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/vte/vte_0.28.2.bb')
-rw-r--r--meta/recipes-support/vte/vte_0.28.2.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta/recipes-support/vte/vte_0.28.2.bb b/meta/recipes-support/vte/vte_0.28.2.bb
new file mode 100644
index 0000000000..c74419adcb
--- /dev/null
+++ b/meta/recipes-support/vte/vte_0.28.2.bb
@@ -0,0 +1,8 @@
+require vte.inc
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7"
+
+PR = "r0"
+
+SRC_URI[archive.md5sum] = "f07a4bf943194f94b7f142db8f7f36dc"
+SRC_URI[archive.sha256sum] = "8d04e202b617373dfb47689e5e628febe2c58840b34cccc4af4feb88c48df903"