summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/vim
diff options
context:
space:
mode:
authorTom Rini <trini@konsulko.com>2019-05-01 08:51:08 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-05-02 09:56:19 +0100
commit554c9904bbd6ef19569b5fca5fb51e7a16b77a3d (patch)
treeb80005b9e6958a02ccccadd1c05f1d01271e2e1b /meta/recipes-support/vim
parentec3c2d46504256afb8b0ea59d2ab67ae3887db1b (diff)
downloadopenembedded-core-contrib-554c9904bbd6ef19569b5fca5fb51e7a16b77a3d.tar.gz
vim: Rework to not rely on relative directories
The vim recipe has all of the code inside the "src" subdirectory but other things we rely on, such as the license file in a subdirectory relative to the src. However, as there is a top-level "configure" script that moves us down to the src directory, we can rework the recipe to be overall more simple and regularly laid out if we use that. (From OE-Core rev: 2eb66c1ff55a3fe9785967f45f1cb6a27df44f93) Signed-off-by: Tom Rini <trini@konsulko.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/vim')
-rw-r--r--meta/recipes-support/vim/vim-tiny_8.1.1017.bb2
-rw-r--r--meta/recipes-support/vim/vim_8.1.1017.bb18
2 files changed, 11 insertions, 9 deletions
diff --git a/meta/recipes-support/vim/vim-tiny_8.1.1017.bb b/meta/recipes-support/vim/vim-tiny_8.1.1017.bb
index 8b1fb7b115..74464833ad 100644
--- a/meta/recipes-support/vim/vim-tiny_8.1.1017.bb
+++ b/meta/recipes-support/vim/vim-tiny_8.1.1017.bb
@@ -8,7 +8,7 @@ ALTERNATIVE_${PN}_remove = "xxd"
PACKAGECONFIG += "tiny"
do_install() {
- install -D -m 0755 ${S}/vim ${D}/${bindir}/vim.tiny
+ install -D -m 0755 ${S}/src/vim ${D}/${bindir}/vim.tiny
}
ALTERNATIVE_PRIORITY = "90"
diff --git a/meta/recipes-support/vim/vim_8.1.1017.bb b/meta/recipes-support/vim/vim_8.1.1017.bb
index 7627d2844b..4e3e663c54 100644
--- a/meta/recipes-support/vim/vim_8.1.1017.bb
+++ b/meta/recipes-support/vim/vim_8.1.1017.bb
@@ -6,16 +6,16 @@ DEPENDS = "ncurses gettext-native"
# vimdiff doesn't like busybox diff
RSUGGESTS_${PN} = "diffutils"
LICENSE = "vim"
-LIC_FILES_CHKSUM = "file://../runtime/doc/uganda.txt;endline=287;md5=f1f82b42360005c70b8c19b0ef493f72"
+LIC_FILES_CHKSUM = "file://runtime/doc/uganda.txt;endline=287;md5=f1f82b42360005c70b8c19b0ef493f72"
SRC_URI = "git://github.com/vim/vim.git \
- file://disable_acl_header_check.patch;patchdir=.. \
- file://vim-add-knob-whether-elf.h-are-checked.patch;patchdir=.. \
- file://0001-src-Makefile-improve-reproducibility.patch;patchdir=.. \
+ file://disable_acl_header_check.patch \
+ file://vim-add-knob-whether-elf.h-are-checked.patch \
+ file://0001-src-Makefile-improve-reproducibility.patch \
"
SRCREV = "493fbe4abee660d30b4f2aef87b754b0a720213c"
-S = "${WORKDIR}/git/src"
+S = "${WORKDIR}/git"
VIMDIR = "vim${@d.getVar('PV').split('.')[0]}${@d.getVar('PV').split('.')[1]}"
@@ -25,13 +25,15 @@ CLEANBROKEN = "1"
# vim configure.in contains functions which got 'dropped' by autotools.bbclass
do_configure () {
+ cd src
rm -f auto/*
touch auto/config.mk
aclocal
autoconf
+ cd ..
oe_runconf
- touch auto/configure
- touch auto/config.mk auto/config.h
+ touch src/auto/configure
+ touch src/auto/config.mk src/auto/config.h
}
#Available PACKAGECONFIG options are gtkgui, acl, x11, tiny
@@ -76,7 +78,7 @@ do_install() {
chmod -x ${D}${datadir}/${BPN}/${VIMDIR}/tools/*.py
# Install example vimrc from runtime files
- install -m 0644 ../runtime/vimrc_example.vim ${D}/${datadir}/${BPN}/vimrc
+ install -m 0644 runtime/vimrc_example.vim ${D}/${datadir}/${BPN}/vimrc
# we use --with-features=big as default
mv ${D}${bindir}/${BPN} ${D}${bindir}/${BPN}.${BPN}