aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/ptest-runner/ptest-runner_2.1.1.bb
diff options
context:
space:
mode:
authorAníbal Limón <anibal.limon@linaro.org>2017-12-12 09:38:17 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-02 17:24:12 +0000
commit843fccd46323268252ea698e3b8ab956dd4b48e0 (patch)
treea306481c9695033bcd93210f9b59d2198fea8680 /meta/recipes-support/ptest-runner/ptest-runner_2.1.1.bb
parent19642e2d6e015072e4a413f4f57aee65df757cb9 (diff)
downloadopenembedded-core-contrib-843fccd46323268252ea698e3b8ab956dd4b48e0.tar.gz
ptest-runner: Upgrade to 2.1.1
Contains fixes, - timeout option missing the argument option ":" to getopt - utils.c: Prefer monotonic clock to calculate elapsed time - Add support to avoid load/run twice a run_ptest script Signed-off-by: Aníbal Limón <anibal.limon@linaro.org> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support/ptest-runner/ptest-runner_2.1.1.bb')
-rw-r--r--meta/recipes-support/ptest-runner/ptest-runner_2.1.1.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-support/ptest-runner/ptest-runner_2.1.1.bb b/meta/recipes-support/ptest-runner/ptest-runner_2.1.1.bb
new file mode 100644
index 0000000000..e5b71c0f01
--- /dev/null
+++ b/meta/recipes-support/ptest-runner/ptest-runner_2.1.1.bb
@@ -0,0 +1,26 @@
+SUMMARY = "A C program to run all installed ptests"
+DESCRIPTION = "The ptest-runner2 package installs a ptest-runner \
+program which loops through all installed ptest test suites and \
+runs them in sequence."
+HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/ptest-runner2/about/"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
+
+SRCREV = "16413d71cc06b02a6d859c35a017cc49b88283f7"
+PV = "2.1.1+git${SRCPV}"
+
+SRC_URI = "git://git.yoctoproject.org/ptest-runner2"
+S = "${WORKDIR}/git"
+
+FILES_${PN} = "${bindir}/ptest-runner"
+
+EXTRA_OEMAKE = "-e MAKEFLAGS="
+
+do_compile () {
+ oe_runmake
+}
+
+do_install () {
+ install -D -m 0755 ${S}/ptest-runner ${D}${bindir}/ptest-runner
+}