aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/ptest-runner/ptest-runner_1.0.bb
diff options
context:
space:
mode:
authorAníbal Limón <anibal.limon@linux.intel.com>2016-01-25 17:29:37 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-29 18:14:52 +0000
commit2a6746cb5e60c9c5477d1df062bb2657d2fe4780 (patch)
tree522167c505d8f3d8cd4dd8ad3ba19db5935465e8 /meta/recipes-support/ptest-runner/ptest-runner_1.0.bb
parent37419969a37b1303be27cb32d76fbea27c8086ce (diff)
downloadopenembedded-core-contrib-2a6746cb5e60c9c5477d1df062bb2657d2fe4780.tar.gz
ptest-runner: Add ptest-runner_2.0 recipe.
The ptest-runner 2.0 is C written program for run ptests of Yocto/Openembedded, is fully compatible with previous version of ptest-runner that was a shell script that runs ptests sequencially. The mainly reason for the new ptest-runner in C is because is designed for run in tiny systems also the old shell script version have problems when certain ptest hang it becomes blocked indefinitely. Now the ptest-runner 2.0 support the next features: - Specify the directory for search ptests. - List available ptests. - Specify the timeout for avoid blocking indefinetly. - Only run certain ptests. Proposed features: - Adds support for per ptest output file. - Adds support for run ptests in parallel (review possible colisions in ptests). [YOCTO #8021] Signed-off-by: Aníbal Limón <anibal.limon@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support/ptest-runner/ptest-runner_1.0.bb')
-rw-r--r--meta/recipes-support/ptest-runner/ptest-runner_1.0.bb24
1 files changed, 0 insertions, 24 deletions
diff --git a/meta/recipes-support/ptest-runner/ptest-runner_1.0.bb b/meta/recipes-support/ptest-runner/ptest-runner_1.0.bb
deleted file mode 100644
index bc1b0a4d46..0000000000
--- a/meta/recipes-support/ptest-runner/ptest-runner_1.0.bb
+++ /dev/null
@@ -1,24 +0,0 @@
-SUMMARY = "A simple shell script to run all installed ptests"
-DESCRIPTION = "The ptest-runner package installs a ptest-runner \
-shell script which loops through all installed ptest test suites and \
-runs them in sequence."
-HOMEPAGE = "https://wiki.yoctoproject.org/wiki/Ptest"
-SRC_URI += "file://ptest-runner"
-
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \
- file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-
-INHIBIT_DEFAULT_DEPS = "1"
-
-S = "${WORKDIR}"
-
-do_install () {
- mkdir -p ${D}${bindir}
- install -m 0755 ${WORKDIR}/ptest-runner ${D}${bindir}
-}
-
-do_patch[noexec] = "1"
-do_configure[noexec] = "1"
-do_compile[noexec] = "1"
-do_build[noexec] = "1"