aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/pinentry/pinentry_0.9.2.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2015-05-18 18:49:50 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-20 21:40:14 +0100
commitfb5f00ae63e0e3ae890254b4286f7160694bf7ee (patch)
tree558cdf274f8a05a7808d8e1d300b84b8236692c9 /meta/recipes-support/pinentry/pinentry_0.9.2.bb
parent027ca092ab201dd1ef56d819d316faea2d68871f (diff)
downloadopenembedded-core-contrib-fb5f00ae63e0e3ae890254b4286f7160694bf7ee.tar.gz
pinentry: package update to 9.2
added a few more PACKAGECONIG options. Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/pinentry/pinentry_0.9.2.bb')
-rw-r--r--meta/recipes-support/pinentry/pinentry_0.9.2.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-support/pinentry/pinentry_0.9.2.bb b/meta/recipes-support/pinentry/pinentry_0.9.2.bb
new file mode 100644
index 0000000000..c836ca4b86
--- /dev/null
+++ b/meta/recipes-support/pinentry/pinentry_0.9.2.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Collection of simple PIN or passphrase entry dialogs"
+DESCRIPTION = "\
+ Pinentry is a collection of simple PIN or passphrase entry dialogs which \
+ utilize the Assuan protocol as described by the aegypten project; see \
+ http://www.gnupg.org/aegypten/ for details."
+
+HOMEPAGE = "http://www.gnupg.org/related_software/pinentry/index.en.html"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=cbbd794e2a0a289b9dfcc9f513d1996e"
+
+inherit autotools
+
+SRC_URI = "ftp://ftp.gnupg.org/gcrypt/${BPN}/${BPN}-${PV}.tar.bz2"
+
+SRC_URI[md5sum] = "f51d454f921111b5156a2291cbf70278"
+SRC_URI[sha256sum] = "fd8bc1592ceb22bb492b07cb29b1b140bb882c859e6503b974254c0a4b4134d1"
+
+EXTRA_OECONF = "--disable-rpath \
+ --disable-dependency-tracking \
+ "
+
+PACKAGECONFIG ??= "ncurses libcap"
+
+PACKAGECONFIG[ncurses] = "--enable-ncurses --with-ncurses-include-dir=${STAGING_INCDIR}, --disable-ncurses, ncurses"
+PACKAGECONFIG[libcap] = "--with-libcap, --without-libcap, libcap"
+PACKAGECONFIG[qt4] = "--enable-pinentry-qt4, --disable-pinentry-qt4, qt4-x11"
+PACKAGECONFIG[qt4_clipboard] = "--enable-pinentry-qt4-clipboard --enable-pinentry-qt4, --disable-pinentry-qt4-clipboard, qt4-x11"
+PACKAGECONFIG[gtk2] = "--enable-pinentry-gtk2, --disable-pinentry-gtk2, gtk+ glib-2.0"
+
+#To use libsecret, add meta-gnome
+PACKAGECONFIG[secret] = "--enable-libsecret, --disable-libsecret, libsecret"