aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/p11-kit/p11-kit_0.23.14.bb
diff options
context:
space:
mode:
authorAlex Kiernan <alex.kiernan@gmail.com>2018-09-20 15:06:05 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-09-21 08:15:19 -0700
commit1a38f27342c5a40f81e579b2d0feb7b6e9880ac7 (patch)
treeefed9f6ee8db637682285e81cd799550b03c8ef0 /meta/recipes-support/p11-kit/p11-kit_0.23.14.bb
parentdfe55fdc34ae32b75934ea42b44d9ab6023e0250 (diff)
downloadopenembedded-core-contrib-1a38f27342c5a40f81e579b2d0feb7b6e9880ac7.tar.gz
p11-kit: Upgrade from 0.22.1 -> 0.23.14
p11-kit is no longer doing odd/even for development/stable releases, so drop the custom UPSTREAM_CHECK_GITTAGREGEX. Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support/p11-kit/p11-kit_0.23.14.bb')
-rw-r--r--meta/recipes-support/p11-kit/p11-kit_0.23.14.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-support/p11-kit/p11-kit_0.23.14.bb b/meta/recipes-support/p11-kit/p11-kit_0.23.14.bb
new file mode 100644
index 0000000000..2a8709143b
--- /dev/null
+++ b/meta/recipes-support/p11-kit/p11-kit_0.23.14.bb
@@ -0,0 +1,44 @@
+SUMMARY = "Provides a way to load and enumerate PKCS#11 modules"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://COPYING;md5=02933887f609807fbb57aa4237d14a50"
+
+inherit autotools gettext pkgconfig gtk-doc
+
+DEPENDS = "libtasn1 libffi"
+
+SRC_URI = "git://github.com/p11-glue/p11-kit \
+ file://0001-LINGUAS-drop-the-languages-for-which-upstream-does-n.patch \
+ "
+SRCREV = "3770793f026e46a000d2d8816d56122598289d5c"
+S = "${WORKDIR}/git"
+
+AUTOTOOLS_AUXDIR = "${S}/build/litter"
+EXTRA_OECONF = "--without-trust-paths"
+
+# This recipe does not use the standard gtk-doc m4 macros, and so the ./configure flags
+# that control gtk-doc build are non-standard
+EXTRA_OECONF_prepend_class-target = "${@bb.utils.contains('GTKDOC_ENABLED', 'True', '--enable-doc --enable-doc-html --disable-doc-pdf', \
+ '--disable-doc', d)} "
+
+# When building native recipes, disable gtkdoc, as it is not necessary,
+# pulls in additional dependencies, and makes build times longer
+EXTRA_OECONF_prepend_class-native = "--disable-doc "
+EXTRA_OECONF_prepend_class-nativesdk = "--disable-doc "
+
+UNKNOWN_CONFIGURE_WHITELIST_append = " --enable-gtk-doc-html --disable-gtk-doc-pdf --enable-gtk-doc --disable-gtk-doc"
+
+# p11-kit relies on these two being copied from source tree
+# instead of being regenerated by gtkdoc-scan, but doesn't setup
+# dependencies correctly when there is a parallel build. Let's pre-copy
+# them instead.
+do_compile_prepend () {
+ cp ${S}/doc/manual/p11-kit-overrides.txt ${S}/doc/manual/p11-kit-sections.txt ${B}/doc/manual/
+}
+
+FILES_${PN} += " \
+ ${libdir}/p11-kit-proxy.so \
+ ${libdir}/pkcs11/*.so \
+ ${libdir}/pkcs11/*.la"
+
+# PN contains p11-kit-proxy.so, a symlink to a loadable module
+INSANE_SKIP_${PN} = "dev-so"