aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/nss
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2016-12-13 20:08:03 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-01-09 13:34:32 +0000
commitd9dca61ed26af166df913f34bdce3f2830682b33 (patch)
tree679378d9e53921754d45b4f17a426b9570c9c01a /meta/recipes-support/nss
parent5d2b0816a92965cdbbb2dca5d3009fbd5064b9ca (diff)
downloadopenembedded-core-contrib-d9dca61ed26af166df913f34bdce3f2830682b33.tar.gz
nss: fix for x32
This was casting to a pointer, and the pointer sizes are 32-bit on X32, not 64-bit. Adjust as appropriate. Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support/nss')
-rw-r--r--meta/recipes-support/nss/nss/Fix-compilation-for-X32.patch31
-rw-r--r--meta/recipes-support/nss/nss_3.27.1.bb1
2 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-support/nss/nss/Fix-compilation-for-X32.patch b/meta/recipes-support/nss/nss/Fix-compilation-for-X32.patch
new file mode 100644
index 0000000000..f7f2c217da
--- /dev/null
+++ b/meta/recipes-support/nss/nss/Fix-compilation-for-X32.patch
@@ -0,0 +1,31 @@
+From c8eadfcdfbc1d5a4799e9a264b0f859cb5954c05 Mon Sep 17 00:00:00 2001
+From: Christopher Larson <chris_larson@mentor.com>
+Date: Tue, 13 Dec 2016 11:40:47 -0700
+Subject: [PATCH 7/7] Fix compilation for X32
+
+X32 uses 32-bit pointers, not 64-bit.
+
+Signed-off-by: Christopher Larson <chris_larson@mentor.com>
+---
+ nss/lib/freebl/poly1305-donna-x64-sse2-incremental-source.c | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/nss/lib/freebl/poly1305-donna-x64-sse2-incremental-source.c b/nss/lib/freebl/poly1305-donna-x64-sse2-incremental-source.c
+index 2a3301e..d4ade41 100644
+--- a/nss/lib/freebl/poly1305-donna-x64-sse2-incremental-source.c
++++ b/nss/lib/freebl/poly1305-donna-x64-sse2-incremental-source.c
+@@ -87,7 +87,11 @@ static poly1305_state_internal INLINE
+ *
+ poly1305_aligned_state(poly1305_state *state)
+ {
++#ifdef __ILP32__
++ return (poly1305_state_internal *)(((uint32_t)state + 63) & ~63);
++#else
+ return (poly1305_state_internal *)(((uint64_t)state + 63) & ~63);
++#endif
+ }
+
+ /* copy 0-63 bytes */
+--
+2.8.0
+
diff --git a/meta/recipes-support/nss/nss_3.27.1.bb b/meta/recipes-support/nss/nss_3.27.1.bb
index a69672b3d8..2a4f4d6d4b 100644
--- a/meta/recipes-support/nss/nss_3.27.1.bb
+++ b/meta/recipes-support/nss/nss_3.27.1.bb
@@ -22,6 +22,7 @@ SRC_URI = "\
file://nss-fix-nsinstall-build.patch \
file://disable-Wvarargs-with-clang.patch \
file://pqg.c-ULL_addend.patch \
+ file://Fix-compilation-for-X32.patch \
file://nss.pc.in \
file://signlibs.sh \
"