aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/neon
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-09-01 19:09:11 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-09-01 19:09:57 +0100
commitd62ee7eaf2ba025c3f64b2d4e10dc7cec4637612 (patch)
treef36fe3008f36ff75cbdd31b630f8f13f1f205ebb /meta/recipes-support/neon
parentcaab7fc509bf27706ff3248689f6afd04225cfda (diff)
downloadopenembedded-core-contrib-d62ee7eaf2ba025c3f64b2d4e10dc7cec4637612.tar.gz
packages: Separate out most of the remaining packages into recipes
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-support/neon')
-rw-r--r--meta/recipes-support/neon/neon-0.29.3/pkgconfig.patch16
-rw-r--r--meta/recipes-support/neon/neon_0.29.3.bb16
2 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-support/neon/neon-0.29.3/pkgconfig.patch b/meta/recipes-support/neon/neon-0.29.3/pkgconfig.patch
new file mode 100644
index 0000000000..6256d9ab2b
--- /dev/null
+++ b/meta/recipes-support/neon/neon-0.29.3/pkgconfig.patch
@@ -0,0 +1,16 @@
+---
+ neon.pc.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- neon-0.28.1.orig/neon.pc.in
++++ neon-0.28.1/neon.pc.in
+@@ -4,8 +4,8 @@ libdir=@libdir@
+ includedir=@includedir@
+
+ Name: neon
+ Description: HTTP/WebDAV client library
+ Version: @NEON_VERSION@
+-Libs.private: @NEON_LIBS@
++Libs.private: -L${libdir} -lz -lgcrypt -lgpg-error -lexpat -lgnutls
+ Libs: -L${libdir} -lneon @NEON_PC_LIBS@
+ Cflags: -I${includedir}/neon @NEON_CFLAGS@
diff --git a/meta/recipes-support/neon/neon_0.29.3.bb b/meta/recipes-support/neon/neon_0.29.3.bb
new file mode 100644
index 0000000000..bb18893f9e
--- /dev/null
+++ b/meta/recipes-support/neon/neon_0.29.3.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "neon is an HTTP and WebDAV client library, with a C interface."
+HOMEPAGE = "http://www.webdav.org/neon/"
+SECTION = "libs"
+LICENSE = "LGPLv2+"
+LIC_FILES_CHKSUM = "file://src/COPYING.LIB;md5=f30a9716ef3762e3467a2f62bf790f0a \
+ file://src/ne_utils.h;beginline=1;endline=20;md5=2caca609538eddaa6f6adf120a218037"
+DEPENDS = "zlib libxml2 expat time gnutls"
+
+PR = "r0"
+
+SRC_URI = "http://www.webdav.org/${PN}/${P}.tar.gz \
+ file://pkgconfig.patch;patch=1"
+
+inherit autotools binconfig lib_package pkgconfig
+
+EXTRA_OECONF = "--with-ssl=gnutls --with-libxml2 --with-expat --enable-shared"