aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/neon
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2015-06-09 19:57:52 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-11 23:59:16 +0100
commitc929827695745cfc847485118d35ee89a5f76fa4 (patch)
treee9dd17b66d867548cf7e57bd917f4e3da2f4aa98 /meta/recipes-support/neon
parentb012fc8b198cea8e6b317e30804c0199ff4d131c (diff)
downloadopenembedded-core-contrib-c929827695745cfc847485118d35ee89a5f76fa4.tar.gz
neon: build the test suite to verify neon links
Without building a binary it's impossible to tell if a library will link correctly, so build the test suite in do_compile(). (From OE-Core rev: 659d0300187accaff393d2b988aef6b58972ed8d) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/neon')
-rw-r--r--meta/recipes-support/neon/neon_0.30.1.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-support/neon/neon_0.30.1.bb b/meta/recipes-support/neon/neon_0.30.1.bb
index 9245244eb8..fd170bc0cb 100644
--- a/meta/recipes-support/neon/neon_0.30.1.bb
+++ b/meta/recipes-support/neon/neon_0.30.1.bb
@@ -20,3 +20,7 @@ inherit autotools binconfig-disabled lib_package pkgconfig
EXTRA_OECONF = "--with-ssl=gnutls --with-libxml2 --with-expat --enable-shared"
EXTRA_OECONF += "--without-gssapi"
+
+do_compile_append() {
+ oe_runmake -C test
+}