aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/neon
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2016-02-03 16:30:33 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-07 17:29:58 +0000
commit562c75c5658434d915204324034ab582cf023c13 (patch)
tree4ec48ed71b746355e56c83e3da164b41f065e18d /meta/recipes-support/neon
parent6228cf8166e4543061c6f1be85cbf02daca3822c (diff)
downloadopenembedded-core-contrib-562c75c5658434d915204324034ab582cf023c13.tar.gz
neon: convert to PACKAGECONFIG
Along with the conversion to PACKAGECONFIG, drop unnecessary dependencies on time (it's an app, not a library?) and libxml2 (neon requires either expat or libxml2 for xml parsing, defaulting to expat if both are available). (From OE-Core rev: e4e5b8a1d3febd72d65392ecec6e2b4de16f4022) Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/neon')
-rw-r--r--meta/recipes-support/neon/neon_0.30.1.bb27
1 files changed, 19 insertions, 8 deletions
diff --git a/meta/recipes-support/neon/neon_0.30.1.bb b/meta/recipes-support/neon/neon_0.30.1.bb
index 0244314a63..b6cfd5076f 100644
--- a/meta/recipes-support/neon/neon_0.30.1.bb
+++ b/meta/recipes-support/neon/neon_0.30.1.bb
@@ -4,24 +4,35 @@ SECTION = "libs"
LICENSE = "LGPLv2+"
LIC_FILES_CHKSUM = "file://src/COPYING.LIB;md5=f30a9716ef3762e3467a2f62bf790f0a \
file://src/ne_utils.h;beginline=1;endline=20;md5=2caca609538eddaa6f6adf120a218037"
-DEPENDS = "zlib libxml2 expat time gnutls libproxy"
-DEPENDS_class-native = "zlib-native libxml2-native expat-native gnutls-native"
-
-BBCLASSEXTEND = "native"
SRC_URI = "http://www.webdav.org/${BPN}/${BPN}-${PV}.tar.gz \
file://pkgconfig.patch \
file://gnutls_4.3_fixup.patch"
+
SRC_URI[md5sum] = "231adebe5c2f78fded3e3df6e958878e"
SRC_URI[sha256sum] = "00c626c0dc18d094ab374dbd9a354915bfe4776433289386ed489c2ec0845cdd"
-BINCONFIG = "${bindir}/neon-config"
-
inherit autotools binconfig-disabled lib_package pkgconfig
-EXTRA_OECONF = "--with-ssl=gnutls --with-libxml2 --with-expat --enable-shared"
-EXTRA_OECONF += "--without-gssapi"
+# Enable gnutls or openssl, not both
+PACKAGECONFIG ?= "expat gnutls libproxy webdav zlib"
+PACKAGECONFIG_class-native = "expat gnutls webdav zlib"
+
+PACKAGECONFIG[expat] = "--with-expat,--without-expat,expat"
+PACKAGECONFIG[gnutls] = "--with-ssl=gnutls,,gnutls"
+PACKAGECONFIG[gssapi] = "--with-gssapi,--without-gssapi,krb5"
+PACKAGECONFIG[libproxy] = "--with-libproxy,--without-libproxy,libproxy"
+PACKAGECONFIG[libxml2] = "--with-libxml2,--without-libxml2,libxml2"
+PACKAGECONFIG[openssl] = "--with-ssl=openssl,,openssl"
+PACKAGECONFIG[webdav] = "--enable-webdav,--disable-webdav,"
+PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib"
+
+EXTRA_OECONF += "--enable-shared"
do_compile_append() {
oe_runmake -C test
}
+
+BINCONFIG = "${bindir}/neon-config"
+
+BBCLASSEXTEND = "native"