aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/lzop/lzop_1.03.bb
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2011-12-08 10:35:31 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-12-12 21:50:08 +0000
commit9b3991cf6a8bb751e45c1abfc48d65d952c048b8 (patch)
treea0708c3268be4afc441a73282596971a8f425132 /meta/recipes-support/lzop/lzop_1.03.bb
parent24498e983ab8455ef0dda67efa8c16c1197f3597 (diff)
downloadopenembedded-core-contrib-9b3991cf6a8bb751e45c1abfc48d65d952c048b8.tar.gz
lzop-1.03: add recipe
This is needed by some kernels when CONFIG_KERNEL_LZO=y (specifically, given the current defconfig, this affects linux-omap4 2.6 in the meta-ti layer). Signed-off-by: Christopher Larson <chris_larson@mentor.com>
Diffstat (limited to 'meta/recipes-support/lzop/lzop_1.03.bb')
-rw-r--r--meta/recipes-support/lzop/lzop_1.03.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-support/lzop/lzop_1.03.bb b/meta/recipes-support/lzop/lzop_1.03.bb
new file mode 100644
index 0000000000..63a2a62c83
--- /dev/null
+++ b/meta/recipes-support/lzop/lzop_1.03.bb
@@ -0,0 +1,27 @@
+SUMMARY = "Real-time file compressor"
+DESCRIPTION = "lzop is a compression utility which is designed to be a companion to gzip. \n\
+It is based on the LZO data compression library and its main advantages over \n\
+gzip are much higher compression and decompression speed at the cost of some \n\
+compression ratio. The lzop compression utility was designed with the goals \n\
+of reliability, speed, portability and with reasonable drop-in compatibility \n\
+to gzip."
+DEPENDS += "lzo"
+PR = "r0"
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=dfeaf3dc4beef4f5a7bdbc35b197f39e \
+ file://src/lzop.c;beginline=5;endline=21;md5=6797bd3ed0a1a49327b7ebf9366ebd86"
+
+SRC_URI = "http://www.lzop.org/download/${BP}.tar.gz \
+ file://acinclude.m4"
+SRC_URI[md5sum] = "006c5e27fb78cdd14a628fdfa5aa1905"
+SRC_URI[sha256sum] = "c1425b8c77d49f5a679d5a126c90ea6ad99585a55e335a613cae59e909dbb2c9"
+
+inherit autotools
+
+do_configure () {
+ ln -sf ../acinclude.m4
+ autotools_do_configure
+}
+
+BBCLASSEXTEND += "native nativesdk"