aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libnl/libnl-2.0/fix-pktloc_syntax_h-race.patch
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2011-11-03 17:52:42 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-11-07 14:03:37 +0000
commita4882cd6f98c5b3df80ba96536d94d9f556f77a2 (patch)
tree7e592fb192aa7713942ce6b7e664df3dfc282e8a /meta/recipes-support/libnl/libnl-2.0/fix-pktloc_syntax_h-race.patch
parentaddcb5106ca0b1849299d6ad4e734135da29b0ab (diff)
downloadopenembedded-core-contrib-a4882cd6f98c5b3df80ba96536d94d9f556f77a2.tar.gz
libnl-2.0: move fix-pktloc_syntax_h-race.patch to libnl-2.0 subdirectory and merge with fix-makefile.patch
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta/recipes-support/libnl/libnl-2.0/fix-pktloc_syntax_h-race.patch')
-rw-r--r--meta/recipes-support/libnl/libnl-2.0/fix-pktloc_syntax_h-race.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-support/libnl/libnl-2.0/fix-pktloc_syntax_h-race.patch b/meta/recipes-support/libnl/libnl-2.0/fix-pktloc_syntax_h-race.patch
new file mode 100644
index 0000000000..ea32e82b66
--- /dev/null
+++ b/meta/recipes-support/libnl/libnl-2.0/fix-pktloc_syntax_h-race.patch
@@ -0,0 +1,29 @@
+Upstream-Status: Inappropriate [configuration]
+
+libnl has progressed to 0.3.2 and there does not appear to be any
+"make -j" issues with this build after my limited testing on that
+newer version so we can assume this issue is fixed upstream
+
+Signed-off-by: Martin Jansa <martin.jansa@gmail.com>
+
+Index: libnl-2.0/lib/Makefile.am
+===================================================================
+--- libnl-2.0.orig/lib/Makefile.am
++++ libnl-2.0/lib/Makefile.am
+@@ -27,11 +27,16 @@ CLEANFILES = \
+ route/pktloc_grammar.c route/pktloc_grammar.h \
+ route/pktloc_syntax.c route/pktloc_syntax.h
+
++BUILT_SOURCES = route/pktloc_syntax.h route/pktloc_grammar.h
++
+ # Hack to avoid using ylwrap. It does not function correctly in combination
+ # with --header-file=
++route/pktloc.lo: route/pktloc_syntax.h route/pktloc_grammar.h
++route/pktloc_grammar.h: route/pktloc_grammar.c
+ route/pktloc_grammar.c: route/pktloc_grammar.l
+ $(LEX) --header-file=route/pktloc_grammar.h $(LFLAGS) -o $@ $^
+
++route/pktloc_syntax.h: route/pktloc_syntax.c
+ route/pktloc_syntax.c: route/pktloc_syntax.y
+ $(YACC) -d $(YFLAGS) -o $@ $^
+