summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libical/libical_3.0.11.bb
diff options
context:
space:
mode:
authorwangmy <wangmy@fujitsu.com>2021-10-13 20:12:49 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-10-16 17:41:05 +0100
commita148c21a03c298933ecac1ca4204eb453ce1c22a (patch)
treed88af0e71fc8214b62c3ce001e7faeb25583d9ce /meta/recipes-support/libical/libical_3.0.11.bb
parent7fd06a57a1d91d8534721923f6e3951ec8220cec (diff)
downloadopenembedded-core-contrib-a148c21a03c298933ecac1ca4204eb453ce1c22a.tar.gz
libical: upgrade 3.0.10 -> 3.0.11
Version 3.0.11 is a patch release. This release is binary and source compatible with version 3.0.0. Note that the libical-glib library is considered unstable; therefore not binary compatible with previous releases ReleaseNotes: Fix icalrecur_iterator_set_start() for hourly, minutely, and secondly recurrences Fix build for Berkeley DB version greater than 5 Fix vcal for some architectures (like aarch64, ppc64le and s390x) Fix memory leaks in vcal Prevent crash when looking for tzid in initialize_rscale Adjust libdir and includedir in generated pkgconfig files Built-in timezones updated to tzdata2021c Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libical/libical_3.0.11.bb')
-rw-r--r--meta/recipes-support/libical/libical_3.0.11.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-support/libical/libical_3.0.11.bb b/meta/recipes-support/libical/libical_3.0.11.bb
new file mode 100644
index 0000000000..b16081e9e2
--- /dev/null
+++ b/meta/recipes-support/libical/libical_3.0.11.bb
@@ -0,0 +1,46 @@
+SUMMARY = "iCal and scheduling (RFC 2445, 2446, 2447) library"
+DESCRIPTION = "An Open Source implementation of the iCalendar protocols \
+and protocol data units. The iCalendar specification describes how \
+calendar clients can communicate with calendar servers so users can store \
+their calendar data and arrange meetings with other users. "
+HOMEPAGE = "https://github.com/libical/libical"
+BUGTRACKER = "https://github.com/libical/libical/issues"
+LICENSE = "LGPLv2.1 | MPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1910a2a76ddf6a9ba369182494170d87 \
+ file://LICENSE.LGPL21.txt;md5=933adb561f159e7c3da079536f0ed871 \
+ file://LICENSE.MPL2.txt;md5=f75d2927d3c1ed2414ef72048f5ad640 \
+ "
+SECTION = "libs"
+
+SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/v${PV}/${BP}.tar.gz \
+"
+SRC_URI[sha256sum] = "1e6c5e10c5a48f7a40c68958055f0e2759d9ab3563aca17273fe35a5df7dbbf1"
+UPSTREAM_CHECK_URI = "https://github.com/libical/libical/releases"
+
+inherit cmake pkgconfig
+
+DEPENDS:append:class-target = " libical-native"
+
+PACKAGECONFIG ??= "icu glib"
+PACKAGECONFIG[bdb] = ",-DCMAKE_DISABLE_FIND_PACKAGE_BDB=True,db"
+PACKAGECONFIG[glib] = "-DICAL_GLIB=True,-DICAL_GLIB=False,glib-2.0-native libxml2-native glib-2.0 libxml2"
+# ICU is used for RSCALE (RFC7529) support
+PACKAGECONFIG[icu] = ",-DCMAKE_DISABLE_FIND_PACKAGE_ICU=True,icu"
+
+# No need to use perl-native, the host perl is sufficient.
+EXTRA_OECMAKE += "-DPERL_EXECUTABLE=${HOSTTOOLS_DIR}/perl"
+# doc build fails with linker error (??) for libical-glib so disable it
+EXTRA_OECMAKE += "-DICAL_BUILD_DOCS=false"
+
+EXTRA_OECMAKE:append:class-target = " -DIMPORT_ICAL_GLIB_SRC_GENERATOR=${STAGING_LIBDIR_NATIVE}/cmake/LibIcal/IcalGlibSrcGenerator.cmake"
+
+do_install:append () {
+ # Remove build host references
+ sed -i \
+ -e 's,${STAGING_LIBDIR},${libdir},g' \
+ -e 's,${STAGING_INCDIR},${includedir},g' \
+ ${D}${libdir}/cmake/LibIcal/LibIcal*.cmake \
+ ${D}${libdir}/cmake/LibIcal/Ical*.cmake
+}
+
+BBCLASSEXTEND = "native"