aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libfm/libfm_1.2.3.bb
diff options
context:
space:
mode:
authorMax Krummenacher <max.oss.09@gmail.com>2015-01-07 23:29:55 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-01-07 23:48:40 +0000
commit4f12442b752626ad5f9711cbb1344720fdb3f47e (patch)
tree5a9e54b07e75734c50533740fe6650b514deb1ba /meta/recipes-support/libfm/libfm_1.2.3.bb
parent29cd284cab63fb1f6e82ad90bc8c92c1bbcafa88 (diff)
downloadopenembedded-core-contrib-4f12442b752626ad5f9711cbb1344720fdb3f47e.tar.gz
libfm: update to 1.2.3
split out libfm-extra as a seperate recipe to break a circular dependency with newer menu-cache recipe. This obsoletes ignore_automake_warnings.patch. This obsoletes fix-make-parallelism-issue.patch. https://github.com/lxde/libfm/commit/24c8eab43cb5b79ca917d67a2c5924aca34c80c9 The library part of libfm has its license changed by the authors to LGPL: http://git.lxde.org/gitweb/?p=lxde/libfm.git;a=commit;h=e0d250aeb40f26ceead82d4b4c7af3b58ab34930 Signed-off-by: Max Krummenacher <max.oss.09@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libfm/libfm_1.2.3.bb')
-rw-r--r--meta/recipes-support/libfm/libfm_1.2.3.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-support/libfm/libfm_1.2.3.bb b/meta/recipes-support/libfm/libfm_1.2.3.bb
new file mode 100644
index 0000000000..856364a60a
--- /dev/null
+++ b/meta/recipes-support/libfm/libfm_1.2.3.bb
@@ -0,0 +1,36 @@
+SUMMARY = "Library for file management"
+HOMEPAGE = "http://pcmanfm.sourceforge.net/"
+
+LICENSE = "GPLv2+ & LGPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
+ file://src/fm.h;beginline=8;endline=21;md5=ef1f84da64b3c01cca447212f7ef6007 \
+ file://src/base/fm-config.h;beginline=10;endline=23;md5=ef1f84da64b3c01cca447212f7ef6007 \
+ file://src/fm-gtk.h;beginline=6;endline=19;md5=646baa4955c04fe768f2ca27b92ac8dd"
+
+
+SECTION = "x11/libs"
+DEPENDS = "glib-2.0 pango gtk+ menu-cache intltool-native libexif libfm-extra"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/pcmanfm/libfm-${PV}.tar.xz"
+
+SRC_URI[md5sum] = "3ff38200701658f7e80e25ed395d92dd"
+SRC_URI[sha256sum] = "c692f1624a4cbc8d1dd55f3b3f3369fbf5d26f63a916e2c295230b2344e1fbf9"
+
+inherit autotools-brokensep pkgconfig gtk-doc
+
+do_configure[dirs] =+ "${S}/m4"
+
+PACKAGES += "${PN}-mime"
+FILES_${PN}-mime = "${datadir}/mime/"
+FILES_${PN}-dbg += "${libdir}/libfm/modules/.debug"
+
+do_install_append () {
+ # remove files which are part of libfm-extra
+ rm -f ${D}${includedir}/libfm-1.0/fm-xml-file.h
+ rm -f ${D}${includedir}/libfm-1.0/fm-version.h
+ rm -f ${D}${includedir}/libfm-1.0/fm-extra.h
+ rm -f ${D}${libdir}/pkgconfig/libfm-extra.pc
+ rm -f ${D}${libdir}/libfm-extra.so*
+ rm -f ${D}${libdir}/libfm-extra.a
+ rm -f ${D}${libdir}/libfm-extra.la
+}