summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libcap-ng/libcap-ng_0.7.9.bb
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2018-03-21 16:36:24 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-04 09:54:49 +0100
commitf98f0e6d8096290fdcc5fc6fc3b15638fa56158f (patch)
tree7849f3eaac8908a2421baed2a0adbab44011bf1d /meta/recipes-support/libcap-ng/libcap-ng_0.7.9.bb
parent4229cdca14d5cd6b6ab3628c8e31aff5f1fe27a8 (diff)
downloadopenembedded-core-contrib-f98f0e6d8096290fdcc5fc6fc3b15638fa56158f.tar.gz
libcap-ng: update to 0.7.9
Rebase python.patch. Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support/libcap-ng/libcap-ng_0.7.9.bb')
-rw-r--r--meta/recipes-support/libcap-ng/libcap-ng_0.7.9.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-support/libcap-ng/libcap-ng_0.7.9.bb b/meta/recipes-support/libcap-ng/libcap-ng_0.7.9.bb
new file mode 100644
index 0000000000..aff6259db2
--- /dev/null
+++ b/meta/recipes-support/libcap-ng/libcap-ng_0.7.9.bb
@@ -0,0 +1,37 @@
+SUMMARY = "An alternate posix capabilities library"
+DESCRIPTION = "The libcap-ng library is intended to make programming \
+with POSIX capabilities much easier than the traditional libcap library."
+HOMEPAGE = "http://freecode.com/projects/libcap-ng"
+SECTION = "base"
+LICENSE = "GPLv2+ & LGPLv2.1+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
+ file://COPYING.LIB;md5=e3eda01d9815f8d24aae2dbd89b68b06"
+
+SRC_URI = "http://people.redhat.com/sgrubb/libcap-ng/libcap-ng-${PV}.tar.gz \
+ file://python.patch"
+
+inherit lib_package autotools python3native
+
+SRC_URI[md5sum] = "2398d695508fab9ce33668c53a89b0e9"
+SRC_URI[sha256sum] = "4a1532bcf3731aade40936f6d6a586ed5a66ca4c7455e1338d1f6c3e09221328"
+
+DEPENDS += "swig-native python3"
+
+EXTRA_OECONF += "--with-python --with-python3"
+EXTRA_OEMAKE += "PYLIBVER='python${PYTHON_BASEVERSION}${PYTHON_ABI}' PYINC='${STAGING_INCDIR}/${PYLIBVER}'"
+
+PACKAGES += "${PN}-python"
+
+FILES_${PN}-python = "${libdir}/python${PYTHON_BASEVERSION}"
+
+BBCLASSEXTEND = "native"
+
+do_install_append() {
+ # Moving libcap-ng to base_libdir
+ if [ ! ${D}${libdir} -ef ${D}${base_libdir} ]; then
+ mkdir -p ${D}/${base_libdir}/
+ mv -f ${D}${libdir}/libcap-ng.so.* ${D}${base_libdir}/
+ relpath=${@os.path.relpath("${base_libdir}", "${libdir}")}
+ ln -sf ${relpath}/libcap-ng.so.0.0.0 ${D}${libdir}/libcap-ng.so
+ fi
+}