summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/icu
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2022-08-22 15:09:49 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-08-23 15:23:27 +0100
commit9b121df8d9f2a46bb08992725f97ba03e878a609 (patch)
tree8415170748a21bc53cd8730337a45e0166858b79 /meta/recipes-support/icu
parent3ec2d27d09444213ec1c9b91c6f8c4363f297294 (diff)
downloadopenembedded-core-contrib-9b121df8d9f2a46bb08992725f97ba03e878a609.tar.gz
icu: Drop binconfig support (icu-config)
Upstream have indicated icu-config is deprecated and they don't intend people to use it any more. Drop our code for it to flush out users and clean up our recipe a bit. pkg-config is a much better alternative. (https://github.com/unicode-org/icu/pull/2150) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/icu')
-rw-r--r--meta/recipes-support/icu/icu_71.1.bb14
1 files changed, 5 insertions, 9 deletions
diff --git a/meta/recipes-support/icu/icu_71.1.bb b/meta/recipes-support/icu/icu_71.1.bb
index d8ef2a3746..b39633c203 100644
--- a/meta/recipes-support/icu/icu_71.1.bb
+++ b/meta/recipes-support/icu/icu_71.1.bb
@@ -15,20 +15,16 @@ S = "${WORKDIR}/icu/source"
SPDX_S = "${WORKDIR}/icu"
STAGING_ICU_DIR_NATIVE = "${STAGING_DATADIR_NATIVE}/${BPN}/${PV}"
-BINCONFIG = "${bindir}/icu-config"
-
ICU_MAJOR_VER = "${@d.getVar('PV').split('.')[0]}"
-inherit autotools pkgconfig binconfig multilib_script
-
-MULTILIB_SCRIPTS = "${PN}-dev:${bindir}/icu-config"
+inherit autotools pkgconfig
# ICU needs the native build directory as an argument to its --with-cross-build option when
# cross-compiling. Taken the situation that different builds may share a common sstate-cache
# into consideration, the native build directory needs to be staged.
-EXTRA_OECONF = "--with-cross-build=${STAGING_ICU_DIR_NATIVE}"
-EXTRA_OECONF:class-native = ""
-EXTRA_OECONF:class-nativesdk = "--with-cross-build=${STAGING_ICU_DIR_NATIVE}"
+EXTRA_OECONF = "--with-cross-build=${STAGING_ICU_DIR_NATIVE} --disable-icu-config"
+EXTRA_OECONF:class-native = "--disable-icu-config"
+EXTRA_OECONF:class-nativesdk = "--with-cross-build=${STAGING_ICU_DIR_NATIVE} --disable-icu-config"
EXTRA_OECONF:append:class-target = "${@oe.utils.conditional('SITEINFO_ENDIANNESS', 'be', ' --with-data-packaging=archive', '', d)}"
TARGET_CXXFLAGS:append = "${@oe.utils.conditional('SITEINFO_ENDIANNESS', 'be', ' -DICU_DATA_DIR=\\""${datadir}/${BPN}/${PV}\\""', '', d)}"
@@ -67,7 +63,7 @@ do_install:append:class-target() {
-e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
-e 's|${DEBUG_PREFIX_MAP}||g' \
-e 's:${HOSTTOOLS_DIR}/::g' \
- ${D}/${bindir}/icu-config ${D}/${libdir}/${BPN}/${PV}/Makefile.inc \
+ ${D}/${libdir}/${BPN}/${PV}/Makefile.inc \
${D}/${libdir}/${BPN}/${PV}/pkgdata.inc
}