aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/gpgme/gpgme_1.4.3.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2013-08-22 16:41:10 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-08-26 11:26:01 +0100
commit3b4f5c4153c0af0e5205d9c30e4b7265c36079d3 (patch)
treed3bb51b21d7ea7834e20b0d0c7e568c9003e4644 /meta/recipes-support/gpgme/gpgme_1.4.3.bb
parent45f80a0c46035dc73818ce4bd818a4f6197d954f (diff)
downloadopenembedded-core-contrib-3b4f5c4153c0af0e5205d9c30e4b7265c36079d3.tar.gz
gpgme: update to 1.4.3
Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-support/gpgme/gpgme_1.4.3.bb')
-rw-r--r--meta/recipes-support/gpgme/gpgme_1.4.3.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-support/gpgme/gpgme_1.4.3.bb b/meta/recipes-support/gpgme/gpgme_1.4.3.bb
new file mode 100644
index 0000000000..aacd92383c
--- /dev/null
+++ b/meta/recipes-support/gpgme/gpgme_1.4.3.bb
@@ -0,0 +1,30 @@
+SUMMARY = "High-level GnuPG encryption/signing API"
+DESCRIPTION = "GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier for applications. It provides a High-Level Crypto API for encryption, decryption, signing, signature verification and key management"
+HOMEPAGE = "http://www.gnupg.org/gpgme.html"
+BUGTRACKER = "https://bugs.g10code.com/gnupg/index"
+
+LICENSE = "GPLv2+ & LGPLv2.1+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
+ file://COPYING.LESSER;md5=bbb461211a33b134d42ed5ee802b37ff \
+ file://src/gpgme.h.in;endline=23;md5=dccb4bb624011e36513c61ef0422d054 \
+ file://src/engine.h;endline=22;md5=4b6d8ba313d9b564cc4d4cfb1640af9d"
+
+SRC_URI = "ftp://ftp.gnupg.org/gcrypt/gpgme/gpgme-${PV}.tar.bz2 \
+ file://disable_gpgconf_check.patch"
+
+SRC_URI[md5sum] = "334e524cffa8af4e2f43ae8afe585672"
+SRC_URI[sha256sum] = "2d1cc12411753752d9c5b9037e6fd3fd363517af720154768cc7b46b60120496"
+
+DEPENDS = "libgpg-error libassuan ${PTH}"
+PTH_libc-uclibc = "npth"
+PTH = "pth"
+
+EXTRA_OECONF = "--with-pth=${STAGING_DIR_HOST} --without-pth-test \
+ --with-gpg=${bindir}/gpg --without-gpgsm"
+
+inherit autotools binconfig
+
+PACKAGES =+ "${PN}-pth ${PN}-pthread"
+FILES_${PN}-pth = "${libdir}/libgpgme-pth.so.*"
+FILES_${PN}-pthread = "${libdir}/libgpgme-pthread.so.*"
+FILES_${PN}-dev += "${datadir}/common-lisp/source/gpgme/*"