aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/gnutls
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2012-01-04 14:27:18 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-01-06 11:27:26 +0000
commit70dc38b1e127524f50f661c5dd4b3225ddb0b36b (patch)
tree7abe45a9f7d648644d35f09bbe357997056622e2 /meta/recipes-support/gnutls
parenta299d91ba422ed2ee34c1c54cdfaff4c88c60754 (diff)
downloadopenembedded-core-contrib-70dc38b1e127524f50f661c5dd4b3225ddb0b36b.tar.gz
gnutls: remove gettext patch for non-GPLv3
GPLv2 version of gnutls does not need the gettext 0.18 patch since it still uses the over version of gettext that is also GPLv2. Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-support/gnutls')
-rw-r--r--meta/recipes-support/gnutls/gnutls_2.12.14.bb13
1 files changed, 10 insertions, 3 deletions
diff --git a/meta/recipes-support/gnutls/gnutls_2.12.14.bb b/meta/recipes-support/gnutls/gnutls_2.12.14.bb
index 045ba69d1b..21fd187285 100644
--- a/meta/recipes-support/gnutls/gnutls_2.12.14.bb
+++ b/meta/recipes-support/gnutls/gnutls_2.12.14.bb
@@ -1,10 +1,17 @@
require gnutls.inc
-PR = "${INC_PR}.3"
+PR = "${INC_PR}.4"
SRC_URI += "file://gnutls-openssl.patch \
- file://configure-fix.patch \
- file://fix-gettext-version.patch"
+ file://configure-fix.patch"
+
+python() {
+ if not ((d.getVar("INCOMPATIBLE_LICENSE", True) or "").find("GPLv3") != -1):
+ # if GPLv3 add patch
+ src_uri = (d.getVar("SRC_URI", False) or "").split()
+ src_uri.append("file://fix-gettext-version.patch")
+ d.setVar("SRC_URI", " ".join(src_uri))
+}
SRC_URI[md5sum] = "555687a7ffefba0bd9de1e71cb61402c"
SRC_URI[sha256sum] = "5ee72ba6de7a23cf315792561954451e022dac8730149ca95f93c61e95be2ce3"