aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/db
diff options
context:
space:
mode:
authorTyler Hall <tylerwhall@gmail.com>2014-01-24 23:14:03 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-01-30 15:01:09 +0000
commit56c21bd1789844a04b2c2eaf01176ba7634ee520 (patch)
tree8e85e483a3c448c0c8a5e8fe8b01bc8903003803 /meta/recipes-support/db
parent600dcd9d3827683371c7a695422636c805305beb (diff)
downloadopenembedded-core-contrib-56c21bd1789844a04b2c2eaf01176ba7634ee520.tar.gz
db: Fix libtool linking against local libstdc++.so
Building the C++ bindings in a484b35b818768487ff27cf06b8c5d4e128126af introduced this error on systems with /usr/lib/libstdc++.so present: /usr/lib/libstdc++.so: file not recognized: File format not recognized The shipped libtool is sysroot aware, so pass --with-sysroot so it will extract the sysroot from the compiler. (From OE-Core rev: db8a2c29b936e5252970c85def927d9cc56a8376) Signed-off-by: Tyler Hall <tylerwhall@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/db')
-rw-r--r--meta/recipes-support/db/db_5.3.21.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-support/db/db_5.3.21.bb b/meta/recipes-support/db/db_5.3.21.bb
index 8ec887007a..caf6890261 100644
--- a/meta/recipes-support/db/db_5.3.21.bb
+++ b/meta/recipes-support/db/db_5.3.21.bb
@@ -63,7 +63,7 @@ FILES_SOLIBSDEV = "${libdir}/libdb.so ${libdir}/libdb_cxx.so"
# All the --disable-* options replace --enable-smallbuild, which breaks a bunch of stuff (eg. postfix)
DB5_CONFIG ?= "--enable-o_direct --disable-cryptography --disable-queue --disable-replication --disable-verify --disable-compat185 --disable-sql"
-EXTRA_OECONF = "${DB5_CONFIG} --enable-shared --enable-cxx"
+EXTRA_OECONF = "${DB5_CONFIG} --enable-shared --enable-cxx --with-sysroot"
# Override the MUTEX setting here, the POSIX library is
# the default - "POSIX/pthreads/library".