aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/curl
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2012-08-06 13:57:04 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-06 15:13:57 +0100
commit666b67179d4492e4d950b94457ebf8cac6454f7d (patch)
treefac66bb4521c52f9381b4dd257a521b843ead55b /meta/recipes-support/curl
parent1aa6c4a083e406de0119f92e9654068d6cc2e4de (diff)
downloadopenembedded-core-contrib-666b67179d4492e4d950b94457ebf8cac6454f7d.tar.gz
curl: disable ldap/ldaps explicitly
* openldap from meta-oe is autodetected and then libldap-2.4-2 runtime dependency added to curl and almost all meta-efl recipes Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/curl')
-rw-r--r--meta/recipes-support/curl/curl_7.26.0.bb12
1 files changed, 7 insertions, 5 deletions
diff --git a/meta/recipes-support/curl/curl_7.26.0.bb b/meta/recipes-support/curl/curl_7.26.0.bb
index f04b4008d6..418e29ca8f 100644
--- a/meta/recipes-support/curl/curl_7.26.0.bb
+++ b/meta/recipes-support/curl/curl_7.26.0.bb
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = "file://COPYING;beginline=7;md5=3a34942f4ae3fbf1a303160714e66
DEPENDS = "zlib gnutls"
DEPENDS_virtclass-native = "zlib-native openssl-native"
DEPENDS_virtclass-nativesdk = "zlib-nativesdk"
-PR = "r0"
+PR = "r1"
SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \
file://pkgconfig_fix.patch"
@@ -20,11 +20,13 @@ inherit autotools pkgconfig binconfig
EXTRA_OECONF = "--with-zlib=${STAGING_LIBDIR}/../ \
--without-libssh2 \
- --with-random=/dev/urandom \
- --without-libidn \
- --enable-crypto-auth \
+ --with-random=/dev/urandom \
+ --without-libidn \
+ --enable-crypto-auth \
+ --disable-ldap \
+ --disable-ldaps \
${CURLGNUTLS} \
- "
+ "
CURLGNUTLS = " --with-gnutls=${STAGING_LIBDIR}/../ --without-ssl"
CURLGNUTLS_virtclass-native = "--without-gnutls --with-ssl"