aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/curl
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2012-10-27 16:48:17 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-11-02 16:15:30 +0000
commitcafb550fe9034754933f1708446dde155dcc3d51 (patch)
treed478075c915cc5ebaf01ce191f5a98acd5f87dcf /meta/recipes-support/curl
parentd37944fff256e9f52d05a56db3edb42c7a352cce (diff)
downloadopenembedded-core-contrib-cafb550fe9034754933f1708446dde155dcc3d51.tar.gz
recipes-support: replace virtclass-native(sdk) with class-native(sdk)
The overrides virtclass-native and virtclass-nativesdk are deprecated, which should be replaced by class-native and class-nativesdk. NOTE: There were 2 errors in libcap.inc, the BUILD_LDFLAGS_virtclass_native should be BUILD_LDFLAGS_virtclass-native (the "_" should be "-"), otherwise it doesn't work, and the value was: "-Wl,rpath=...", this is incorrect, it shoudl be: "-Wl,-rpath=..." (lacked a - ), but we don't need this line, since it is already in the default BUILD_LDFLAGS. Remove it and we don't need to bump the PR since we just removed a unused line. [YOCTO #3297] Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-support/curl')
-rw-r--r--meta/recipes-support/curl/curl_7.26.0.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-support/curl/curl_7.26.0.bb b/meta/recipes-support/curl/curl_7.26.0.bb
index dad5572dff..9a0e7ce27e 100644
--- a/meta/recipes-support/curl/curl_7.26.0.bb
+++ b/meta/recipes-support/curl/curl_7.26.0.bb
@@ -6,8 +6,8 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://COPYING;beginline=7;md5=3a34942f4ae3fbf1a303160714e664ac"
DEPENDS = "zlib gnutls"
-DEPENDS_virtclass-native = "zlib-native openssl-native"
-DEPENDS_virtclass-nativesdk = "nativesdk-zlib"
+DEPENDS_class-native = "zlib-native openssl-native"
+DEPENDS_class-nativesdk = "nativesdk-zlib"
PR = "r1"
SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \
@@ -29,8 +29,8 @@ EXTRA_OECONF = "--with-zlib=${STAGING_LIBDIR}/../ \
"
CURLGNUTLS = " --with-gnutls=${STAGING_LIBDIR}/../ --without-ssl"
-CURLGNUTLS_virtclass-native = "--without-gnutls --with-ssl"
-CURLGNUTLS_virtclass-nativesdk = "--without-gnutls --without-ssl"
+CURLGNUTLS_class-native = "--without-gnutls --with-ssl"
+CURLGNUTLS_class-nativesdk = "--without-gnutls --without-ssl"
do_configure_prepend() {
sed -i s:OPT_GNUTLS/bin:OPT_GNUTLS:g configure.ac