aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/curl/curl_7.47.1.bb
diff options
context:
space:
mode:
authorRoy Li <rongqing.li@windriver.com>2016-04-26 13:13:01 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-05-06 10:30:58 +0100
commit78811b6e608452a3137df6ed2346c69d42d8fd27 (patch)
tree12ef7f3504c0c1c712eeea7831c95720dbbdd8c7 /meta/recipes-support/curl/curl_7.47.1.bb
parent7157261014e1dcbe9a57e7504dbb0ab2a53aa4d8 (diff)
downloadopenembedded-core-contrib-78811b6e608452a3137df6ed2346c69d42d8fd27.tar.gz
curl: add krb5 to PACKAGECONFIG
krb5 is needed to enables GSS-Negotiate authentication Signed-off-by: Roy Li <rongqing.li@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support/curl/curl_7.47.1.bb')
-rw-r--r--meta/recipes-support/curl/curl_7.47.1.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-support/curl/curl_7.47.1.bb b/meta/recipes-support/curl/curl_7.47.1.bb
index c2173d8a06..b237b4ec9b 100644
--- a/meta/recipes-support/curl/curl_7.47.1.bb
+++ b/meta/recipes-support/curl/curl_7.47.1.bb
@@ -5,7 +5,9 @@ SECTION = "console/network"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://COPYING;beginline=8;md5=3a34942f4ae3fbf1a303160714e664ac"
-SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2"
+SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \
+ file://0001-replace-krb5-config-with-pkg-config.patch \
+"
# curl likes to set -g0 in CFLAGS, so we stop it
# from mucking around with debug options
@@ -40,6 +42,7 @@ PACKAGECONFIG[ssl] = "--with-ssl --with-random=/dev/urandom,--without-ssl,openss
PACKAGECONFIG[telnet] = "--enable-telnet,--disable-telnet,"
PACKAGECONFIG[tftp] = "--enable-tftp,--disable-tftp,"
PACKAGECONFIG[zlib] = "--with-zlib=${STAGING_LIBDIR}/../,--without-zlib,zlib"
+PACKAGECONFIG[krb5] = "--with-gssapi,--without-gssapi,krb5"
EXTRA_OECONF = " \
--enable-crypto-auth \