aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/curl/curl
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-09-01 19:09:11 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-09-01 19:09:57 +0100
commitd62ee7eaf2ba025c3f64b2d4e10dc7cec4637612 (patch)
treef36fe3008f36ff75cbdd31b630f8f13f1f205ebb /meta/recipes-support/curl/curl
parentcaab7fc509bf27706ff3248689f6afd04225cfda (diff)
downloadopenembedded-core-contrib-d62ee7eaf2ba025c3f64b2d4e10dc7cec4637612.tar.gz
packages: Separate out most of the remaining packages into recipes
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-support/curl/curl')
-rw-r--r--meta/recipes-support/curl/curl/noldlibpath.patch74
-rw-r--r--meta/recipes-support/curl/curl/pkgconfig_fix.patch35
2 files changed, 109 insertions, 0 deletions
diff --git a/meta/recipes-support/curl/curl/noldlibpath.patch b/meta/recipes-support/curl/curl/noldlibpath.patch
new file mode 100644
index 0000000000..a3319a23e3
--- /dev/null
+++ b/meta/recipes-support/curl/curl/noldlibpath.patch
@@ -0,0 +1,74 @@
+Manipulating LD_LIBRARY_PATH can totally break builds when cross compiling.
+Since we never run compiled binaries for the target, we should *never* need
+to change LD_LIBRARY_PATH.
+
+RP 9/6/2010
+
+Index: curl-7.20.0/configure.ac
+===================================================================
+--- curl-7.20.0.orig/configure.ac 2010-06-09 11:06:30.000000000 +0100
++++ curl-7.20.0/configure.ac 2010-06-09 11:04:25.000000000 +0100
+@@ -1461,9 +1461,10 @@
+ dnl linker doesn't search through, we need to add it to LD_LIBRARY_PATH
+ dnl to prevent further configure tests to fail due to this
+
+- LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$LIB_OPENSSL"
+- export LD_LIBRARY_PATH
+- AC_MSG_NOTICE([Added $LIB_OPENSSL to LD_LIBRARY_PATH])
++ #LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$LIB_OPENSSL"
++ #export LD_LIBRARY_PATH
++ #AC_MSG_NOTICE([Added $LIB_OPENSSL to LD_LIBRARY_PATH])
++ :
+ fi
+ fi
+
+@@ -1684,9 +1686,10 @@
+ dnl LD_LIBRARY_PATH to prevent further configure tests to fail
+ dnl due to this
+
+- LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$gtlslib"
+- export LD_LIBRARY_PATH
+- AC_MSG_NOTICE([Added $gtlslib to LD_LIBRARY_PATH])
++ #LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$gtlslib"
++ #export LD_LIBRARY_PATH
++ #AC_MSG_NOTICE([Added $gtlslib to LD_LIBRARY_PATH])
++ :
+ fi
+ fi
+
+@@ -1696,6 +1699,8 @@
+
+ fi dnl OPENSSL != 1
+
++AC_SUBST(GNUTLS_REQUIRED)
++
+ dnl ----------------------------------------------------
+ dnl NSS. Only check if GnuTLS and OpenSSL are not enabled
+ dnl ----------------------------------------------------
+@@ -1781,9 +1786,10 @@
+ dnl LD_LIBRARY_PATH to prevent further configure tests to fail
+ dnl due to this
+
+- LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$nssprefix/lib$libsuff"
+- export LD_LIBRARY_PATH
+- AC_MSG_NOTICE([Added $nssprefix/lib$libsuff to LD_LIBRARY_PATH])
++ #LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$nssprefix/lib$libsuff"
++ #export LD_LIBRARY_PATH
++ #AC_MSG_NOTICE([Added $nssprefix/lib$libsuff to LD_LIBRARY_PATH])
++ :
+ fi
+
+ fi
+@@ -1881,9 +1887,9 @@
+ dnl libssh2_version is a post 1.0 addition
+ AC_CHECK_FUNCS( libssh2_version )
+
+- LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$DIR_SSH2"
+- export LD_LIBRARY_PATH
+- AC_MSG_NOTICE([Added $DIR_SSH2 to LD_LIBRARY_PATH])
++ #LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$DIR_SSH2"
++ #export LD_LIBRARY_PATH
++ #AC_MSG_NOTICE([Added $DIR_SSH2 to LD_LIBRARY_PATH])
+ fi
+ else
+ dnl no libssh2, revert back to clean variables
diff --git a/meta/recipes-support/curl/curl/pkgconfig_fix.patch b/meta/recipes-support/curl/curl/pkgconfig_fix.patch
new file mode 100644
index 0000000000..a59d39b8b1
--- /dev/null
+++ b/meta/recipes-support/curl/curl/pkgconfig_fix.patch
@@ -0,0 +1,35 @@
+Index: curl-7.20.0/libcurl.pc.in
+===================================================================
+--- curl-7.20.0.orig/libcurl.pc.in 2009-11-17 18:11:07.000000000 +0000
++++ curl-7.20.0/libcurl.pc.in 2010-03-25 12:13:26.814051066 +0000
+@@ -35,6 +35,7 @@
+ URL: http://curl.haxx.se/
+ Description: Library to transfer files with ftp, http, etc.
+ Version: @VERSION@
+-Libs: -L${libdir} -lcurl @LIBS@
+-Libs.private: @LIBCURL_LIBS@ @LIBS@
++Requires.private: @GNUTLS_REQUIRED@
++Libs: -L${libdir} -lcurl
++Libs.private: -ldl -lz
+ Cflags: -I${includedir}
+Index: curl-7.20.0/configure.ac
+===================================================================
+--- curl-7.20.0.orig/configure.ac 2010-02-04 21:41:46.000000000 +0000
++++ curl-7.20.0/configure.ac 2010-03-25 12:12:18.673129001 +0000
+@@ -1668,6 +1668,7 @@
+ AC_SUBST(USE_GNUTLS, [1])
+ GNUTLS_ENABLED=1
+ USE_GNUTLS="yes"
++ GNUTLS_REQUIRED="gnutls"
+ curl_ssl_msg="enabled (GnuTLS)"
+ ],
+ [
+@@ -1696,6 +1697,8 @@
+
+ fi dnl OPENSSL != 1
+
++AC_SUBST(GNUTLS_REQUIRED)
++
+ dnl ----------------------------------------------------
+ dnl NSS. Only check if GnuTLS and OpenSSL are not enabled
+ dnl ----------------------------------------------------