aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/boost/boost_1.56.0.bb
diff options
context:
space:
mode:
authorPeter A. Bigot <pab@pabigot.com>2014-09-28 10:37:46 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-09-29 14:35:13 +0100
commitabf8baba208927a0156bb4b743614c6252f2af21 (patch)
tree369447cda15a851c36dcc55953802eb9f13fbbe7 /meta/recipes-support/boost/boost_1.56.0.bb
parent76a2d6b83472995edbe967aed80f0fcbb784b3fc (diff)
downloadopenembedded-core-contrib-abf8baba208927a0156bb4b743614c6252f2af21.tar.gz
boost: fix atomics for armv6
meta-raspberrypi and some other systems are ARMv6k but tell OE that they're ARMv6 which doesn't fully support non-word atomics. armv6k does, but Boost didn't handle the recognition correctly in the 1.56 release. Backport the patch that fixes the build. See: https://svn.boost.org/trac/boost/ticket/10446 Signed-off-by: Peter A. Bigot <pab@pabigot.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/boost/boost_1.56.0.bb')
-rw-r--r--meta/recipes-support/boost/boost_1.56.0.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-support/boost/boost_1.56.0.bb b/meta/recipes-support/boost/boost_1.56.0.bb
index b199c88577..dcc77bb87e 100644
--- a/meta/recipes-support/boost/boost_1.56.0.bb
+++ b/meta/recipes-support/boost/boost_1.56.0.bb
@@ -1,4 +1,7 @@
include boost-${PV}.inc
include boost.inc
-SRC_URI += "file://arm-intrinsics.patch"
+SRC_URI += "\
+ file://arm-intrinsics.patch \
+ file://0001-Added-support-for-extending-operations-to-GCC-atomic.patch;striplevel=2 \
+"