summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/boost/bjam-native_1.71.0.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-08-26 16:26:28 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-08-27 22:52:41 +0100
commit810aded01fc2ae2c27c2573135c20947453e50c6 (patch)
tree75fc26d6a6c3921beb007e42c073d7d75040881b /meta/recipes-support/boost/bjam-native_1.71.0.bb
parent66719424096eb0d3470647579364efe1556dc7b6 (diff)
downloadopenembedded-core-contrib-810aded01fc2ae2c27c2573135c20947453e50c6.tar.gz
boost: update to 1.71.0
Some notes: - bjam bootstrap scripts were changed, and the patch for that had to be adjusted. tools/build/src/engine/build.sh now supports an --debug option which the bjam-native recipe can use to get the debug build of b2. - a related patch was added to address a speed regression with the debug version of bjam - gcc.jam patch had to be refreshed because boost added more "cpu-flags" lines. - since 1.70.0, boost includes new cmake config files which are packaged in ${PN}-dev now so they make it into the SDK. (although 1.71.0 is needed to fix some bugs in them) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/boost/bjam-native_1.71.0.bb')
-rw-r--r--meta/recipes-support/boost/bjam-native_1.71.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-support/boost/bjam-native_1.71.0.bb b/meta/recipes-support/boost/bjam-native_1.71.0.bb
new file mode 100644
index 0000000000..d843eb038c
--- /dev/null
+++ b/meta/recipes-support/boost/bjam-native_1.71.0.bb
@@ -0,0 +1,20 @@
+require boost-${PV}.inc
+
+SUMMARY = "Portable Boost.Jam build tool for boost"
+SECTION = "devel"
+
+inherit native
+
+SRC_URI += "file://0001-Build-debug-version-of-bjam.patch \
+ file://0001-build.sh-use-DNDEBUG-also-in-debug-builds.patch \
+ "
+
+do_compile() {
+ ./bootstrap.sh --with-toolset=gcc
+}
+
+do_install() {
+ install -d ${D}${bindir}/
+ # install unstripped version for bjam
+ install -c -m 755 b2 ${D}${bindir}/bjam
+}