aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/boost/bjam-native_1.68.0.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2018-09-06 12:29:22 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-09-06 23:43:34 +0100
commitfb646ea311c589a51ef76eea7581e63f8a8f6bbd (patch)
treef4d10784b21d0638b34f8d7969cdd278222b9cdf /meta/recipes-support/boost/bjam-native_1.68.0.bb
parent68685bfc83051105ab2c5a5fb7d350ecaca2457f (diff)
downloadopenembedded-core-contrib-fb646ea311c589a51ef76eea7581e63f8a8f6bbd.tar.gz
boost: update to 1.68.0
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/boost/bjam-native_1.68.0.bb')
-rw-r--r--meta/recipes-support/boost/bjam-native_1.68.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-support/boost/bjam-native_1.68.0.bb b/meta/recipes-support/boost/bjam-native_1.68.0.bb
new file mode 100644
index 0000000000..94f96e62d8
--- /dev/null
+++ b/meta/recipes-support/boost/bjam-native_1.68.0.bb
@@ -0,0 +1,19 @@
+require boost-${PV}.inc
+
+SUMMARY = "Portable Boost.Jam build tool for boost"
+SECTION = "devel"
+
+inherit native
+
+SRC_URI += "file://bjam-native-build-bjam.debug.patch \
+"
+
+do_compile() {
+ ./bootstrap.sh --with-toolset=gcc
+}
+
+do_install() {
+ install -d ${D}${bindir}/
+ # install unstripped version for bjam
+ install -c -m 755 bjam.debug ${D}${bindir}/bjam
+}