aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/boost/bjam-native_1.63.0.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2017-02-22 16:51:04 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-01 12:54:22 +0000
commitef603f41b5df4772bb598ec9d389dd5f858592af (patch)
tree143b55b5e49fc5b7fde0cc1121e23b08903b57bc /meta/recipes-support/boost/bjam-native_1.63.0.bb
parentac5c08ea00816852a712a8d7025bce7e865460ec (diff)
downloadopenembedded-core-contrib-ef603f41b5df4772bb598ec9d389dd5f858592af.tar.gz
boost: update to 1.63.0
Drop backported 0002-boost-test-execution_monitor.hpp-fix-mips-soft-float.patch Rebase consider-hardfp.patch to 0001-When-using-soft-float-on-ARM-we-should-not-expect-th.patch Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support/boost/bjam-native_1.63.0.bb')
-rw-r--r--meta/recipes-support/boost/bjam-native_1.63.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta/recipes-support/boost/bjam-native_1.63.0.bb b/meta/recipes-support/boost/bjam-native_1.63.0.bb
new file mode 100644
index 0000000000..46013f343b
--- /dev/null
+++ b/meta/recipes-support/boost/bjam-native_1.63.0.bb
@@ -0,0 +1,18 @@
+require boost-${PV}.inc
+
+SUMMARY = "Portable Boost.Jam build tool for boost"
+SECTION = "devel"
+
+inherit native
+
+SRC_URI += "file://bjam-native-build-bjam.debug.patch"
+
+do_compile() {
+ ./bootstrap.sh --with-toolset=gcc
+}
+
+do_install() {
+ install -d ${D}${bindir}/
+ # install unstripped version for bjam
+ install -c -m 755 bjam.debug ${D}${bindir}/bjam
+}