aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/boost/bjam-native_1.62.0.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-10-18 16:28:18 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-10-28 11:27:33 +0100
commitc31030d87cd1741a4186d711325b8eab9c70b327 (patch)
treea6a4621ca6ba2921d6f47bab6345ad6798a5fd6a /meta/recipes-support/boost/bjam-native_1.62.0.bb
parent1e9fb4e0c529044d0c51c0c7fe02f7c1f4439d17 (diff)
downloadopenembedded-core-contrib-c31030d87cd1741a4186d711325b8eab9c70b327.tar.gz
boost: update to 1.62.0
Remove backported 0003-smart_ptr-mips-assembly-doesn-t-compile-in-mips16e-m.patch Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support/boost/bjam-native_1.62.0.bb')
-rw-r--r--meta/recipes-support/boost/bjam-native_1.62.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta/recipes-support/boost/bjam-native_1.62.0.bb b/meta/recipes-support/boost/bjam-native_1.62.0.bb
new file mode 100644
index 0000000000..32646d707b
--- /dev/null
+++ b/meta/recipes-support/boost/bjam-native_1.62.0.bb
@@ -0,0 +1,18 @@
+include boost-${PV}.inc
+
+SUMMARY = "Portable Boost.Jam build tool for boost"
+SECTION = "devel"
+
+inherit native
+
+SRC_URI += "file://bjam-native-build-bjam.debug.patch"
+
+do_compile() {
+ ./bootstrap.sh --with-toolset=gcc
+}
+
+do_install() {
+ install -d ${D}${bindir}/
+ # install unstripped version for bjam
+ install -c -m 755 bjam.debug ${D}${bindir}/bjam
+}