aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/boost/bjam-native_1.58.0.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2015-05-22 08:26:46 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-23 08:10:13 +0100
commit96320445e357ac45549074f6ec8c39c965e581bb (patch)
treef9a64fce6df37ba469e2953abe3051c773c496be /meta/recipes-support/boost/bjam-native_1.58.0.bb
parent2fb0edcb47a14e47780d545f60885b36e71fca71 (diff)
downloadopenembedded-core-contrib-96320445e357ac45549074f6ec8c39c965e581bb.tar.gz
boost/bjam-native: Upgrade to 1.58.0
Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support/boost/bjam-native_1.58.0.bb')
-rw-r--r--meta/recipes-support/boost/bjam-native_1.58.0.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta/recipes-support/boost/bjam-native_1.58.0.bb b/meta/recipes-support/boost/bjam-native_1.58.0.bb
new file mode 100644
index 0000000000..d85d1a96cb
--- /dev/null
+++ b/meta/recipes-support/boost/bjam-native_1.58.0.bb
@@ -0,0 +1,15 @@
+include boost-${PV}.inc
+
+SUMMARY = "Portable Boost.Jam build tool for boost"
+SECTION = "devel"
+
+inherit native
+
+do_compile() {
+ ./bootstrap.sh --with-toolset=gcc
+}
+
+do_install() {
+ install -d ${D}${bindir}/
+ install -c -m 755 bjam ${D}${bindir}/
+}