aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/boost/bjam-native_1.56.0.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2014-08-19 07:49:09 -0700
committerAndreas Oberritter <obi@opendreambox.org>2015-02-23 17:15:45 +0100
commitaccb3b2393d17dfada2bbc8a6e858c3e8a29bba4 (patch)
treefa860e237b5335160e8a6104059fa49bccc9df53 /meta/recipes-support/boost/bjam-native_1.56.0.bb
parent8473ec3cac2a63d060c3aac21699cded91098994 (diff)
downloadopenembedded-core-contrib-accb3b2393d17dfada2bbc8a6e858c3e8a29bba4.tar.gz
boost: Upgrade to 1.56.0
Rebase boostconfig to handle moved user-config file Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit a6afd754290cecbe57392d13477557051b438817) Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
Diffstat (limited to 'meta/recipes-support/boost/bjam-native_1.56.0.bb')
-rw-r--r--meta/recipes-support/boost/bjam-native_1.56.0.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta/recipes-support/boost/bjam-native_1.56.0.bb b/meta/recipes-support/boost/bjam-native_1.56.0.bb
new file mode 100644
index 0000000000..59a031032c
--- /dev/null
+++ b/meta/recipes-support/boost/bjam-native_1.56.0.bb
@@ -0,0 +1,15 @@
+include boost-${PV}.inc
+
+DESCRIPTION = "Portable Boost.Jam build tool for boost"
+SECTION = "devel"
+
+inherit native
+
+do_compile() {
+ ./bootstrap.sh --with-toolset=gcc
+}
+
+do_install() {
+ install -d ${D}${bindir}/
+ install -c -m 755 bjam ${D}${bindir}/
+}