aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/bmap-tools/bmap-tools_3.4.bb
diff options
context:
space:
mode:
authorEd Bartosh <ed.bartosh@linux.intel.com>2017-09-06 15:08:23 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-09-11 17:30:12 +0100
commitfa36678698108023242f2afbd4e54d6709f84420 (patch)
treeb83dde8b49a3b858e6420dffcfd503c3c72776bd /meta/recipes-support/bmap-tools/bmap-tools_3.4.bb
parentacc9994a77972c49a98aabbfd579973885c95f10 (diff)
downloadopenembedded-core-contrib-fa36678698108023242f2afbd4e54d6709f84420.tar.gz
bmap-tools: upgrade to v3.4
Upgraded to the latest upstream release. Signed-off-by: Ed Bartosh <ed.bartosh@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support/bmap-tools/bmap-tools_3.4.bb')
-rw-r--r--meta/recipes-support/bmap-tools/bmap-tools_3.4.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-support/bmap-tools/bmap-tools_3.4.bb b/meta/recipes-support/bmap-tools/bmap-tools_3.4.bb
new file mode 100644
index 0000000000..3f75fad44b
--- /dev/null
+++ b/meta/recipes-support/bmap-tools/bmap-tools_3.4.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Tools to generate block map (AKA bmap) and flash images using bmap"
+DESCRIPTION = "Bmap-tools - tools to generate block map (AKA bmap) and flash images using \
+bmap. Bmaptool is a generic tool for creating the block map (bmap) for a file, \
+and copying files using the block map. The idea is that large file containing \
+unused blocks, like raw system image files, can be copied or flashed a lot \
+faster with bmaptool than with traditional tools like "dd" or "cp"."
+HOMEPAGE = "https://github.com/01org/bmap-tools"
+SECTION = "console/utils"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRC_URI = "git://github.com/01org/bmap-tools.git"
+SRCREV = "9dad724104df265442226972a1e310813f9ffcba"
+
+S = "${WORKDIR}/git"
+
+RDEPENDS_${PN} = "python-core python-compression python-mmap"
+
+inherit setuptools
+
+BBCLASSEXTEND = "native"
+
+do_install_append_class-native() {
+ sed -i -e 's|^#!.*/usr/bin/python-native/python|#! /usr/bin/env nativepython|' ${D}${bindir}/bmaptool
+}