summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2019-04-17 14:18:03 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-04-23 23:30:19 +0100
commitff9448f915369db8ed9ae7f4ccc617f3912172d6 (patch)
tree6a85a5bf9aa6c5a3440ea7a8e7a1be6a522cbc8a /meta/recipes-sato
parenta5dd314fba9e0571ab9af81d6f91c48d8ebfd14a (diff)
downloadopenembedded-core-contrib-ff9448f915369db8ed9ae7f4ccc617f3912172d6.tar.gz
core-image-sato-ptest-fast: Add 'fast' ptest execution image
Create a common include file which lists recipes that have ptests divided into 'fast' and 'slow' groups. This allows us to include ptests which otherwise may not get included in images and allows us to test the faster running things more regularly. The new image allows access to these faster executing tests. 'fast' is defined as tests which execute in under 30s roughly speaking. (From OE-Core rev: 2d8f8ab85d98929b0f1f699f256b40b1d9cddaec) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato')
-rw-r--r--meta/recipes-sato/images/core-image-sato-ptest-fast.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta/recipes-sato/images/core-image-sato-ptest-fast.bb b/meta/recipes-sato/images/core-image-sato-ptest-fast.bb
new file mode 100644
index 0000000000..b794a7dc9e
--- /dev/null
+++ b/meta/recipes-sato/images/core-image-sato-ptest-fast.bb
@@ -0,0 +1,16 @@
+require core-image-sato-sdk.bb
+require conf/distro/include/ptest-packagelists.inc
+
+IMAGE_INSTALL += "${PTESTS_FAST}"
+
+DESCRIPTION += "Also includes ptest packages with fast execution times to allow for more automated QA."
+
+# This image is sufficiently large (~1.8GB) that it can't actually fit in a live
+# image (which has a 4GB limit), so nullify the overhead factor (1.3x out of the
+# box) and explicitly add just 1500MB.
+# strace-ptest in particular needs more than 500MB
+IMAGE_OVERHEAD_FACTOR = "1.0"
+IMAGE_ROOTFS_EXTRA_SPACE = "1524288"
+
+# ptests need more memory than standard to avoid the OOM killer
+QB_MEM = "-m 1024"