summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato
diff options
context:
space:
mode:
authorEran Matityahu <eran.m@variscite.com>2017-07-30 18:24:19 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-15 10:56:50 +0100
commitdbdcadb57ccdb53be1b84217eb8e3146c0a6ff72 (patch)
tree0dc889a5b19bd096ef8a02187e4ddf371a0dcd93 /meta/recipes-sato
parenta6abac49bd85ec5a45e3234d710605c90821e842 (diff)
downloadopenembedded-core-contrib-dbdcadb57ccdb53be1b84217eb8e3146c0a6ff72.tar.gz
matchbox-session-sato: Make the battery applet depend on machine features
matchbox-panel enables the battery plugin only if the acpi/apm machine features are enabled, so enable the battery applet in the session script under the same conditions. This avoids the 'Failed to load applet "battery"' warning at runtime, in case these machine features are not defined. (From OE-Core rev: 34b5d507d62ef501fe771bd38cf45d25785dbc90) Signed-off-by: Eran Matityahu <eran.m@variscite.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato')
-rw-r--r--meta/recipes-sato/matchbox-sato/matchbox-session-sato/session5
-rw-r--r--meta/recipes-sato/matchbox-sato/matchbox-session-sato_0.1.bb2
2 files changed, 5 insertions, 2 deletions
diff --git a/meta/recipes-sato/matchbox-sato/matchbox-session-sato/session b/meta/recipes-sato/matchbox-sato/matchbox-session-sato/session
index f6313bdebe..3a70574af9 100644
--- a/meta/recipes-sato/matchbox-sato/matchbox-session-sato/session
+++ b/meta/recipes-sato/matchbox-sato/matchbox-session-sato/session
@@ -20,7 +20,10 @@ matchbox-desktop &
# doesn't have the feature "foo".
START_APPLETS=showdesktop,windowselector
-END_APPLETS=clock,battery,$KEYBOARD_APPLET,systray,startup-notify,notify
+END_APPLETS=$KEYBOARD_APPLET,systray,startup-notify,notify
+END_APPLETS=battery,$END_APPLETS # feature-acpi
+END_APPLETS=battery,$END_APPLETS # feature-apm
+END_APPLETS=clock,$END_APPLETS
END_APPLETS=openmoko-panel-gsm,$END_APPLETS # feature-phone
matchbox-panel --start-applets $START_APPLETS --end-applets $END_APPLETS &
diff --git a/meta/recipes-sato/matchbox-sato/matchbox-session-sato_0.1.bb b/meta/recipes-sato/matchbox-sato/matchbox-session-sato_0.1.bb
index d146e836d5..8230e95140 100644
--- a/meta/recipes-sato/matchbox-sato/matchbox-session-sato_0.1.bb
+++ b/meta/recipes-sato/matchbox-sato/matchbox-session-sato_0.1.bb
@@ -26,7 +26,7 @@ FILES_${PN} += "${datadir}/themes/Sato/index.theme"
do_install() {
# This is the set of machine features that the script has markers for
- FEATURES="phone"
+ FEATURES="acpi apm phone"
SCRIPT="${S}/sedder"
rm -f $SCRIPT
touch $SCRIPT