summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-04-19 18:27:38 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-04-26 10:09:02 +0100
commitf1741a8209e56cdf51223678239a680d8788f71f (patch)
tree6b31a03e5877a4b55208440ac8cf0c3b227d0be8 /meta/recipes-sato
parente0a1ae3863bc229512d43e4a5248551bf25950e5 (diff)
downloadopenembedded-core-contrib-f1741a8209e56cdf51223678239a680d8788f71f.tar.gz
webkitgtk: Fix build with clang
Newer version of webkitgtk has some compile failures with clang/libc++ combination. Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato')
-rw-r--r--meta/recipes-sato/webkit/webkitgtk/include_array.patch15
-rw-r--r--meta/recipes-sato/webkit/webkitgtk/narrowing.patch31
-rw-r--r--meta/recipes-sato/webkit/webkitgtk/snprintf.patch15
-rw-r--r--meta/recipes-sato/webkit/webkitgtk_2.24.0.bb3
4 files changed, 64 insertions, 0 deletions
diff --git a/meta/recipes-sato/webkit/webkitgtk/include_array.patch b/meta/recipes-sato/webkit/webkitgtk/include_array.patch
new file mode 100644
index 0000000000..7268b04bf4
--- /dev/null
+++ b/meta/recipes-sato/webkit/webkitgtk/include_array.patch
@@ -0,0 +1,15 @@
+Added missing include for std::array
+
+Upstream-Status: Submitted [https://bugs.webkit.org/show_bug.cgi?id=197085]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+--- webkitgtk-2.24.0/Source/JavaScriptCore/assembler/PerfLog.cpp.org 2019-04-18 18:03:50.226231691 -0700
++++ webkitgtk-2.24.0/Source/JavaScriptCore/assembler/PerfLog.cpp 2019-04-18 18:07:28.569153989 -0700
+@@ -31,6 +31,7 @@
+ #include <elf.h>
+ #include <fcntl.h>
+ #include <mutex>
++#include <array>
+ #include <sys/mman.h>
+ #include <sys/stat.h>
+ #include <sys/syscall.h>
diff --git a/meta/recipes-sato/webkit/webkitgtk/narrowing.patch b/meta/recipes-sato/webkit/webkitgtk/narrowing.patch
new file mode 100644
index 0000000000..598b6b5df5
--- /dev/null
+++ b/meta/recipes-sato/webkit/webkitgtk/narrowing.patch
@@ -0,0 +1,31 @@
+Fix build with clang on arm where char is unsigned
+
+Upstream-Status: Submitted [https://bugs.webkit.org/show_bug.cgi?id=197087]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+--- a/Source/WebCore/contentextensions/DFACombiner.cpp
++++ b/Source/WebCore/contentextensions/DFACombiner.cpp
+@@ -37,7 +37,7 @@ namespace WebCore {
+ namespace ContentExtensions {
+
+ class DFAMerger {
+- typedef MutableRangeList<char, uint64_t, 128> CombinedTransitionsMutableRangeList;
++ typedef MutableRangeList<signed char, uint64_t, 128> CombinedTransitionsMutableRangeList;
+
+ enum class WhichDFA {
+ A,
+--- a/Source/WebCore/contentextensions/NFAToDFA.cpp
++++ b/Source/WebCore/contentextensions/NFAToDFA.cpp
+@@ -41,9 +41,9 @@ namespace WebCore {
+
+ namespace ContentExtensions {
+
+-typedef MutableRange<char, NFANodeIndexSet> NFANodeRange;
+-typedef MutableRangeList<char, NFANodeIndexSet> NFANodeRangeList;
+-typedef MutableRangeList<char, NFANodeIndexSet, 128> PreallocatedNFANodeRangeList;
++typedef MutableRange<signed char, NFANodeIndexSet> NFANodeRange;
++typedef MutableRangeList<signed char, NFANodeIndexSet> NFANodeRangeList;
++typedef MutableRangeList<signed char, NFANodeIndexSet, 128> PreallocatedNFANodeRangeList;
+ typedef Vector<uint32_t, 0, ContentExtensionsOverflowHandler> UniqueNodeList;
+ typedef Vector<UniqueNodeList, 0, ContentExtensionsOverflowHandler> NFANodeClosures;
+
diff --git a/meta/recipes-sato/webkit/webkitgtk/snprintf.patch b/meta/recipes-sato/webkit/webkitgtk/snprintf.patch
new file mode 100644
index 0000000000..b1481d78e8
--- /dev/null
+++ b/meta/recipes-sato/webkit/webkitgtk/snprintf.patch
@@ -0,0 +1,15 @@
+include missing header for snprintf definition
+
+Upstream-Status: Submitted [https://bugs.webkit.org/show_bug.cgi?id=197088]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+--- a/Source/WebCore/platform/text/TextCodec.cpp
++++ b/Source/WebCore/platform/text/TextCodec.cpp
+@@ -28,6 +28,7 @@
+ #include "TextCodec.h"
+
+ #include <array>
++#include <cstdio>
+
+ namespace WebCore {
+
diff --git a/meta/recipes-sato/webkit/webkitgtk_2.24.0.bb b/meta/recipes-sato/webkit/webkitgtk_2.24.0.bb
index 58c06dc8bc..808c92a378 100644
--- a/meta/recipes-sato/webkit/webkitgtk_2.24.0.bb
+++ b/meta/recipes-sato/webkit/webkitgtk_2.24.0.bb
@@ -20,6 +20,9 @@ SRC_URI = "http://www.webkitgtk.org/releases/${BPN}-${PV}.tar.xz \
file://0001-WebKitMacros-Append-to-I-and-not-to-isystem.patch \
file://0001-Fix-build-with-musl.patch \
file://detect-gstreamer-gl.patch \
+ file://include_array.patch \
+ file://narrowing.patch \
+ file://snprintf.patch \
"
SRC_URI[md5sum] = "576d69c598b3e36c73441052d02466de"