summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-08-30 14:49:58 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-08-30 22:25:30 +0100
commit62c1a8ead15d58fb1f159dc6cd6cf22fa8183426 (patch)
treeab176a8ad6fc2855461c4f9a6ae9eb947e887815 /meta/recipes-sato
parente7c544f80859d532c64dd6b1988c762bdd09dbbf (diff)
downloadopenembedded-core-contrib-62c1a8ead15d58fb1f159dc6cd6cf22fa8183426.tar.gz
webkitgtk: update 2.24.3 -> 2.24.4
In particular this brings an important fix for builds with py3: "Fix build issue which would cause media controls to disappear when Python 3.x was used during the build process." https://webkitgtk.org/2019/08/28/webkitgtk2.24.4-released.html Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato')
-rw-r--r--meta/recipes-sato/webkit/webkitgtk/0001-Tweak-gtkdoc-settings-so-that-gtkdoc-generation-work.patch10
-rw-r--r--meta/recipes-sato/webkit/webkitgtk/0001-Unreviewed-fix-build-failure-https-bugs.webkit.org-s.patch33
-rw-r--r--meta/recipes-sato/webkit/webkitgtk_2.24.4.bb (renamed from meta/recipes-sato/webkit/webkitgtk_2.24.3.bb)5
3 files changed, 7 insertions, 41 deletions
diff --git a/meta/recipes-sato/webkit/webkitgtk/0001-Tweak-gtkdoc-settings-so-that-gtkdoc-generation-work.patch b/meta/recipes-sato/webkit/webkitgtk/0001-Tweak-gtkdoc-settings-so-that-gtkdoc-generation-work.patch
index 664cea9c75..e7c668c040 100644
--- a/meta/recipes-sato/webkit/webkitgtk/0001-Tweak-gtkdoc-settings-so-that-gtkdoc-generation-work.patch
+++ b/meta/recipes-sato/webkit/webkitgtk/0001-Tweak-gtkdoc-settings-so-that-gtkdoc-generation-work.patch
@@ -1,4 +1,4 @@
-From d3796ad1a19233ee5d3492a5560d7ede882f89cf Mon Sep 17 00:00:00 2001
+From 4b5e02212a31b82fc9b3becad90542274816fc29 Mon Sep 17 00:00:00 2001
From: Alexander Kanavin <alex.kanavin@gmail.com>
Date: Thu, 11 Aug 2016 17:13:51 +0300
Subject: [PATCH] Tweak gtkdoc settings so that gtkdoc generation works under
@@ -17,23 +17,23 @@ Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/Source/cmake/GtkDoc.cmake b/Source/cmake/GtkDoc.cmake
-index 2ee05550..6cb6313d 100644
+index b0fb31ca..6cb6313d 100644
--- a/Source/cmake/GtkDoc.cmake
+++ b/Source/cmake/GtkDoc.cmake
@@ -4,7 +4,7 @@ macro(ADD_GTKDOC_GENERATOR _stamp_name _extra_args)
add_custom_command(
OUTPUT "${CMAKE_BINARY_DIR}/${_stamp_name}"
DEPENDS ${DocumentationDependencies}
-- COMMAND ${CMAKE_COMMAND} -E env "CC=${CMAKE_C_COMPILER}" "CFLAGS=${CMAKE_C_FLAGS} -Wno-unused-parameter" ${CMAKE_SOURCE_DIR}/Tools/gtkdoc/generate-gtkdoc ${_extra_args}
+- COMMAND ${CMAKE_COMMAND} -E env "CC=${CMAKE_C_COMPILER}" "CFLAGS=${CMAKE_C_FLAGS} -Wno-unused-parameter" "LDFLAGS=${CMAKE_EXE_LINKER_FLAGS}" ${CMAKE_SOURCE_DIR}/Tools/gtkdoc/generate-gtkdoc ${_extra_args}
+ COMMAND ${CMAKE_COMMAND} -E env "CC=${CMAKE_C_COMPILER}" "CFLAGS=${CMAKE_C_FLAGS} -Wno-unused-parameter" "LD=${CMAKE_C_COMPILER}" "LDFLAGS=${CMAKE_C_LINK_FLAGS}" "RUN=${CMAKE_BINARY_DIR}/gtkdoc-qemuwrapper" ${CMAKE_SOURCE_DIR}/Tools/gtkdoc/generate-gtkdoc ${_extra_args}
COMMAND touch ${_stamp_name}
WORKING_DIRECTORY "${CMAKE_BINARY_DIR}"
VERBATIM
diff --git a/Tools/gtkdoc/gtkdoc.py b/Tools/gtkdoc/gtkdoc.py
-index 81ee8cdc..3e11c2f0 100644
+index 054cafa1..416de7d1 100644
--- a/Tools/gtkdoc/gtkdoc.py
+++ b/Tools/gtkdoc/gtkdoc.py
-@@ -317,9 +317,9 @@ class GTKDoc(object):
+@@ -320,9 +320,9 @@ class GTKDoc(object):
additional_ldflags = '%s %s' % (additional_ldflags, arg)
ldflags = ' "-L%s" %s ' % (self.library_path, additional_ldflags) + ldflags
current_ld_library_path = env.get('LD_LIBRARY_PATH')
diff --git a/meta/recipes-sato/webkit/webkitgtk/0001-Unreviewed-fix-build-failure-https-bugs.webkit.org-s.patch b/meta/recipes-sato/webkit/webkitgtk/0001-Unreviewed-fix-build-failure-https-bugs.webkit.org-s.patch
deleted file mode 100644
index e550a0d457..0000000000
--- a/meta/recipes-sato/webkit/webkitgtk/0001-Unreviewed-fix-build-failure-https-bugs.webkit.org-s.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From 4bc241539246f7a17d07357257ab47cb96bc4b69 Mon Sep 17 00:00:00 2001
-From: "ysuzuki@apple.com" <ysuzuki@apple.com>
-Date: Thu, 18 Apr 2019 07:30:18 +0000
-Subject: [PATCH] Unreviewed, fix build failure
- https://bugs.webkit.org/show_bug.cgi?id=195938
-
-Including <array>.
-
-* bmalloc/AvailableMemory.cpp:
-
-git-svn-id: http://svn.webkit.org/repository/webkit/trunk@244422 268f45cc-cd09-0410-ab3c-d52691b4dbfc
-
-Upstream-Status: Backport [https://github.com/WebKit/webkit/commit/84c111dc0d83b5acf60706ef49bc2f5e91112471]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- Source/bmalloc/bmalloc/AvailableMemory.cpp | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/Source/bmalloc/bmalloc/AvailableMemory.cpp b/Source/bmalloc/bmalloc/AvailableMemory.cpp
-index 595889fe..b72000d5 100644
---- a/Source/bmalloc/bmalloc/AvailableMemory.cpp
-+++ b/Source/bmalloc/bmalloc/AvailableMemory.cpp
-@@ -32,6 +32,7 @@
- #include "PerProcess.h"
- #include "Scavenger.h"
- #include "Sizes.h"
-+#include <array>
- #include <mutex>
- #if BOS(DARWIN)
- #if BPLATFORM(IOS_FAMILY)
---
-2.22.0
-
diff --git a/meta/recipes-sato/webkit/webkitgtk_2.24.3.bb b/meta/recipes-sato/webkit/webkitgtk_2.24.4.bb
index 7108242168..8c695ce9e7 100644
--- a/meta/recipes-sato/webkit/webkitgtk_2.24.3.bb
+++ b/meta/recipes-sato/webkit/webkitgtk_2.24.4.bb
@@ -23,11 +23,10 @@ SRC_URI = "http://www.webkitgtk.org/releases/${BPN}-${PV}.tar.xz \
file://include_array.patch \
file://narrowing.patch \
file://0001-gstreamer-add-a-missing-format-string.patch \
- file://0001-Unreviewed-fix-build-failure-https-bugs.webkit.org-s.patch \
"
-SRC_URI[md5sum] = "e2a5bbd09a217eba096a2d1562143e35"
-SRC_URI[sha256sum] = "940d746d7e82c357222feb5b3f44c4b201e81df7d81ddca5ca2bf3ae0acf6c51"
+SRC_URI[md5sum] = "c214963d8c0e7d83460da04a0d8dda87"
+SRC_URI[sha256sum] = "8668b129c026624ec226a4cccf4995f9d26f3e88fc28ab75b0e965f3c32b7dd8"
inherit cmake pkgconfig gobject-introspection perlnative distro_features_check upstream-version-is-even gtk-doc