summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato
diff options
context:
space:
mode:
authorRoss Burton <ross@burtonini.com>2022-01-31 13:54:06 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-02-01 07:29:44 +0000
commit50ff1f018a670c963e1979dee76ebd696153b4c1 (patch)
tree87332e800cbd27b1cfc99b8141bb6f0a475ecc06 /meta/recipes-sato
parent96442e681c3acd82b09e3becd78e902709945f1f (diff)
downloadopenembedded-core-contrib-50ff1f018a670c963e1979dee76ebd696153b4c1.tar.gz
core-image-sato-sdk: allocate more memory when in qemu
Compiling code is memory-intensive, especially kernel modules like the SystemTap probes, so give the VM 768MB of RAM. Using 1GB appears to cause PCI error, interestingly. Hopefully this solves the intermittent failures caused by OOMs during the SystemTap test. [ YOCTO #14673 ] Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato')
-rw-r--r--meta/recipes-sato/images/core-image-sato-sdk.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-sato/images/core-image-sato-sdk.bb b/meta/recipes-sato/images/core-image-sato-sdk.bb
index b52de0def0..afab473b52 100644
--- a/meta/recipes-sato/images/core-image-sato-sdk.bb
+++ b/meta/recipes-sato/images/core-image-sato-sdk.bb
@@ -10,3 +10,6 @@ IMAGE_FEATURES += "dev-pkgs tools-sdk \
IMAGE_INSTALL += "kernel-devsrc"
+# Compiling stuff, specifically SystemTap probes, can require lots of memory
+# See https://bugzilla.yoctoproject.org/show_bug.cgi?id=14673
+QB_MEM = "-m 768"