aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/webkit/webkitgtk_2.14.2.bb
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2016-12-16 11:02:08 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-01-09 13:34:32 +0000
commit79f7e215ee7c176f02efafe7359aaa77dbd9430c (patch)
treecca2dd597c06ba61508b4989bc0360c034b629f8 /meta/recipes-sato/webkit/webkitgtk_2.14.2.bb
parent72fa7d558a43ed053547ddc74972631504e40614 (diff)
downloadopenembedded-core-contrib-79f7e215ee7c176f02efafe7359aaa77dbd9430c.tar.gz
webkitgtk: patch & disable JIT for x32
It might not be speedy, but it does build now. Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-sato/webkit/webkitgtk_2.14.2.bb')
-rw-r--r--meta/recipes-sato/webkit/webkitgtk_2.14.2.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta/recipes-sato/webkit/webkitgtk_2.14.2.bb b/meta/recipes-sato/webkit/webkitgtk_2.14.2.bb
index 46b54683fb..9720432302 100644
--- a/meta/recipes-sato/webkit/webkitgtk_2.14.2.bb
+++ b/meta/recipes-sato/webkit/webkitgtk_2.14.2.bb
@@ -20,6 +20,7 @@ SRC_URI = "http://www.webkitgtk.org/releases/${BPN}-${PV}.tar.xz \
file://0001-Tweak-gtkdoc-settings-so-that-gtkdoc-generation-work.patch \
file://0001-WebKitMacros-Append-to-I-and-not-to-isystem.patch \
file://detect_atomics.patch \
+ file://x32_support.patch \
"
SRC_URI[md5sum] = "2fe3cadbc546d93ca68a13756c2be015"
@@ -85,6 +86,12 @@ EXTRA_OECMAKE_append_toolchain-clang = " -DUSE_LD_GOLD=OFF "
# JIT not supported on MIPS either
EXTRA_OECMAKE_append_mipsarch = " -DENABLE_JIT=OFF "
+# JIT not supported on X32
+# An attempt was made to upstream JIT support for x32 in
+# https://bugs.webkit.org/show_bug.cgi?id=100450, but this was closed as
+# unresolved due to limited X32 adoption.
+EXTRA_OECMAKE_append_linux-gnux32 = " -DENABLE_JIT=OFF"
+
SECURITY_CFLAGS_remove_aarch64 = "-fpie"
SECURITY_CFLAGS_append_aarch64 = " -fPIE"