aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-08-30 11:48:50 +0100
committerSaul Wold <sgw@linux.intel.com>2012-09-03 22:52:51 -0700
commit46cc375f29d5ecac7311613514a474f288d7c781 (patch)
tree2e1de166877dbb1cae073c7261e7d88875736296 /meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb
parent65fca4458cfe1d647c7ea1d4588dc449739a73eb (diff)
downloadopenembedded-core-contrib-46cc375f29d5ecac7311613514a474f288d7c781.tar.gz
packagegroup-core-x11: move out Sato applications
Move Sato applications to packagegroup-core-x11-sato. Note that this eliminates both the apps-x11-core and apps-x11-games IMAGE_FEATURES; in practice it is unlikely these were useful to anyone outside of the Sato images however. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb')
-rw-r--r--meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb40
1 files changed, 33 insertions, 7 deletions
diff --git a/meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb b/meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb
index f38e0d2800..b31eabad11 100644
--- a/meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb
+++ b/meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb
@@ -12,25 +12,51 @@ inherit packagegroup
PACKAGE_ARCH = "${MACHINE_ARCH}"
+PACKAGES = "${PN} ${PN}-base ${PN}-apps ${PN}-games"
+
+RDEPENDS_${PN} = "\
+ ${PN}-base \
+ ${PN}-apps \
+ ${PN}-games \
+ "
+
NETWORK_MANAGER ?= "connman-gnome"
NETWORK_MANAGER_libc-uclibc = ""
-WEB ?= ""
-#WEB = "web-webkit"
-
-RDEPENDS_packagegroup-core-x11-sato = "\
+RDEPENDS_${PN}-base = "\
matchbox-desktop \
matchbox-session-sato \
matchbox-keyboard \
+ matchbox-keyboard-applet \
+ matchbox-keyboard-im \
matchbox-stroke \
matchbox-config-gtk \
xcursor-transparent-theme \
sato-icon-theme \
settings-daemon \
gtk-sato-engine \
- gthumb \
- x11vnc \
libsdl \
+ ${NETWORK_MANAGER} \
+ "
+
+# pcmanfm doesn't work on mips
+FILEMANAGER ?= "pcmanfm"
+FILEMANAGER_mips ?= ""
+
+WEB ?= ""
+#WEB = "web-webkit"
+
+RDEPENDS_${PN}-apps = "\
+ gthumb \
+ leafpad \
gaku \
+ x11vnc \
+ matchbox-terminal \
+ sato-screenshot \
+ ${FILEMANAGER} \
${WEB} \
- ${NETWORK_MANAGER}"
+ "
+
+RDEPENDS_${PN}-games = "\
+ oh-puzzles \
+ "