aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/matchbox-desktop
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2016-06-01 10:57:32 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-15 17:52:25 +0100
commit42d92eabcd6e54db551f6b2577ae6b6da0b778b8 (patch)
tree265795cda486cc2f131fbf34962b6da39e7daf46 /meta/recipes-sato/matchbox-desktop
parent0c32b6e9585a39b14002a5da230222d2fe01ddff (diff)
downloadopenembedded-core-contrib-42d92eabcd6e54db551f6b2577ae6b6da0b778b8.tar.gz
matchbox-desktop: Add Sato folder configuration
matchbox-desktop folder configuration for Sato was in a separate project 'matchbox-desktop-sato'. Skip the extra overhead: remove matchbox-desktop-sato and include the files here. Drop Utilities folder and include those icons in the Applictions folder in an effort to make the common case a little more useful: Now e.g. Terminal icon should be visible on startup. Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-sato/matchbox-desktop')
-rw-r--r--meta/recipes-sato/matchbox-desktop/files/vfolders/All.directory5
-rw-r--r--meta/recipes-sato/matchbox-desktop/files/vfolders/Applications.directory6
-rw-r--r--meta/recipes-sato/matchbox-desktop/files/vfolders/Games.directory9
-rw-r--r--meta/recipes-sato/matchbox-desktop/files/vfolders/Root.order4
-rw-r--r--meta/recipes-sato/matchbox-desktop/files/vfolders/Settings.directory8
-rw-r--r--meta/recipes-sato/matchbox-desktop/matchbox-desktop_2.1.bb11
6 files changed, 42 insertions, 1 deletions
diff --git a/meta/recipes-sato/matchbox-desktop/files/vfolders/All.directory b/meta/recipes-sato/matchbox-desktop/files/vfolders/All.directory
new file mode 100644
index 0000000000..dfa41e3d31
--- /dev/null
+++ b/meta/recipes-sato/matchbox-desktop/files/vfolders/All.directory
@@ -0,0 +1,5 @@
+[Desktop Entry]
+Name=All
+Icon=mbfolder.png
+Type=Directory
+Match=meta-all
diff --git a/meta/recipes-sato/matchbox-desktop/files/vfolders/Applications.directory b/meta/recipes-sato/matchbox-desktop/files/vfolders/Applications.directory
new file mode 100644
index 0000000000..a7e3501712
--- /dev/null
+++ b/meta/recipes-sato/matchbox-desktop/files/vfolders/Applications.directory
@@ -0,0 +1,6 @@
+[Desktop Entry]
+Name=Applications
+Comment=Applications
+Icon=gnome-applications.png
+Type=Directory
+Match=AudioVideo;Audio;Video;Graphics;Network;Office;Utility;System;Development;meta-fallback;
diff --git a/meta/recipes-sato/matchbox-desktop/files/vfolders/Games.directory b/meta/recipes-sato/matchbox-desktop/files/vfolders/Games.directory
new file mode 100644
index 0000000000..1b0928c752
--- /dev/null
+++ b/meta/recipes-sato/matchbox-desktop/files/vfolders/Games.directory
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Games
+Name[de]=Spiele
+Comment=Games of all kind
+Comment[de]=Spiele aller Art
+Icon=mbfolder.png
+Type=Directory
+Match=Game
+
diff --git a/meta/recipes-sato/matchbox-desktop/files/vfolders/Root.order b/meta/recipes-sato/matchbox-desktop/files/vfolders/Root.order
new file mode 100644
index 0000000000..01a86d2939
--- /dev/null
+++ b/meta/recipes-sato/matchbox-desktop/files/vfolders/Root.order
@@ -0,0 +1,4 @@
+Applications
+Games
+Settings
+All
diff --git a/meta/recipes-sato/matchbox-desktop/files/vfolders/Settings.directory b/meta/recipes-sato/matchbox-desktop/files/vfolders/Settings.directory
new file mode 100644
index 0000000000..5dde365f0e
--- /dev/null
+++ b/meta/recipes-sato/matchbox-desktop/files/vfolders/Settings.directory
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Settings
+Name[de]=Einstellungen
+Comment=Settings for your handheld computer
+Comment[de]=Einstellungen für Ihren Handheld-Computer
+Icon=mbfolder.png
+Type=Directory
+Match=Settings
diff --git a/meta/recipes-sato/matchbox-desktop/matchbox-desktop_2.1.bb b/meta/recipes-sato/matchbox-desktop/matchbox-desktop_2.1.bb
index d6c53b003c..d9a2f22147 100644
--- a/meta/recipes-sato/matchbox-desktop/matchbox-desktop_2.1.bb
+++ b/meta/recipes-sato/matchbox-desktop/matchbox-desktop_2.1.bb
@@ -12,7 +12,9 @@ SECTION = "x11/wm"
# SRCREV tagged 2.1
SRCREV = "c8473519a0f37488b8b3e839e275b000cdde0b80"
-SRC_URI = "git://git.yoctoproject.org/${BPN}-2"
+SRC_URI = "git://git.yoctoproject.org/${BPN}-2 \
+ file://vfolders/* \
+ "
EXTRA_OECONF = "--enable-startup-notification --with-dbus"
@@ -22,3 +24,10 @@ inherit autotools pkgconfig distro_features_check
# The startup-notification requires x11 in DISTRO_FEATURES
REQUIRED_DISTRO_FEATURES = "x11"
+
+do_install_append() {
+ install -d ${D}${datadir}/matchbox/vfolders/
+ install -m 0644 ${WORKDIR}/vfolders/* ${D}${datadir}/matchbox/vfolders/
+}
+
+FILES_${PN} += "${datadir}/matchbox/vfolders/"