aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/matchbox-config-gtk
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-05-10 19:17:07 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-14 11:41:11 +0100
commit1722ce23075a00e111145cad6daa2ef87ba391fe (patch)
tree68aba0e232beca1f632d13b3ee798b48af9298c8 /meta/recipes-sato/matchbox-config-gtk
parent777080af697d35b3f983465d6a094f4171e57e56 (diff)
downloadopenembedded-core-contrib-1722ce23075a00e111145cad6daa2ef87ba391fe.tar.gz
libowl/settings-daemon/libnotify: add x11 to REQUIRED_DISTRO_FEATURES
The libowl, settings-daemon and libnotify requires gdk/gdkx.h which is provided by gtk when x11 in DISTRO_FEATURES, so add x11 to REQUIRED_DISTRO_FEATURES. The leafpad, settings-daemon and oh-puzzles requires libowl or settings-daemon, so add xx to REQUIRED_DISTRO_FEATURES for them too. The leafpad can't be built without libowl, so depends in directly rather than use DEPENDS_append_poky. Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Diffstat (limited to 'meta/recipes-sato/matchbox-config-gtk')
-rw-r--r--meta/recipes-sato/matchbox-config-gtk/matchbox-config-gtk_git.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-sato/matchbox-config-gtk/matchbox-config-gtk_git.bb b/meta/recipes-sato/matchbox-config-gtk/matchbox-config-gtk_git.bb
index f0119b7073..5f73a4c48d 100644
--- a/meta/recipes-sato/matchbox-config-gtk/matchbox-config-gtk_git.bb
+++ b/meta/recipes-sato/matchbox-config-gtk/matchbox-config-gtk_git.bb
@@ -17,5 +17,7 @@ S = "${WORKDIR}/git"
SRC_URI = "git://git.yoctoproject.org/${BPN} \
file://no-handed.patch;striplevel=0"
-inherit autotools pkgconfig
+inherit autotools pkgconfig distro_features_check
+# The settings-daemon requires x11 in DISTRO_FEATURES
+REQUIRED_DISTRO_FEATURES = "x11"