summaryrefslogtreecommitdiffstats
path: root/meta/recipes-rt
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-06-02 12:26:06 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-02 11:45:26 +0100
commit4aa0d34155834e2e1ef7972c5dd6490a6f0c49e8 (patch)
treea35634319f321f84fd318f835b39808742da02f7 /meta/recipes-rt
parent671a8e58aba0a01ad8571995dadbf569706df954 (diff)
downloadopenembedded-core-contrib-4aa0d34155834e2e1ef7972c5dd6490a6f0c49e8.tar.gz
hwlatdetect: move to Python 3
Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-rt')
-rw-r--r--meta/recipes-rt/rt-tests/hwlatdetect_0.96.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta/recipes-rt/rt-tests/hwlatdetect_0.96.bb b/meta/recipes-rt/rt-tests/hwlatdetect_0.96.bb
index 025eb63232..012b2dd0a7 100644
--- a/meta/recipes-rt/rt-tests/hwlatdetect_0.96.bb
+++ b/meta/recipes-rt/rt-tests/hwlatdetect_0.96.bb
@@ -6,7 +6,7 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
require rt-tests.inc
-inherit python-dir
+inherit python3-dir
EXTRA_OEMAKE += "PYLIB=${libdir}/python${PYTHON_BASEVERSION}/dist-packages"
@@ -17,8 +17,10 @@ do_compile() {
do_install() {
oe_runmake install_hwlatdetect DESTDIR=${D} SBINDIR=${sbindir} \
MANDIR=${mandir} INCLUDEDIR=${includedir}
+
+ sed -i -e '1s,#!.*python.*,#!${bindir}/python3,' ${D}${libdir}/python${PYTHON_BASEVERSION}/dist-packages/hwlatdetect.py
}
FILES_${PN} += "${libdir}/python${PYTHON_BASEVERSION}/dist-packages/hwlatdetect.py"
-RDEPENDS_${PN} = "python python-subprocess python-textutils"
+RDEPENDS_${PN} = "python3 python3-subprocess python3-textutils"
RRECOMMENDS_${PN} = "kernel-module-hwlat-detector"