aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-rt/rt-tests/hwlatdetect_0.85.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2012-11-16 11:56:27 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-11-21 16:46:42 +0000
commit42fc047daa524ce4f1b9b1b2937d75375d796e6f (patch)
treed3b87dc88dfe66fabf7e86adc1fd14216bdc7deb /meta/recipes-rt/rt-tests/hwlatdetect_0.85.bb
parent41f3104d1993f374e9e289ac74f821261808f833 (diff)
downloadopenembedded-core-contrib-42fc047daa524ce4f1b9b1b2937d75375d796e6f.tar.gz
rt-tests/hwlatdetect: Update to 0.85
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-rt/rt-tests/hwlatdetect_0.85.bb')
-rw-r--r--meta/recipes-rt/rt-tests/hwlatdetect_0.85.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-rt/rt-tests/hwlatdetect_0.85.bb b/meta/recipes-rt/rt-tests/hwlatdetect_0.85.bb
new file mode 100644
index 0000000000..a850a2d42a
--- /dev/null
+++ b/meta/recipes-rt/rt-tests/hwlatdetect_0.85.bb
@@ -0,0 +1,24 @@
+pickDESCRIPTION = "Python hardware latency detector"
+HOMEPAGE = "http://git.kernel.org/?p=linux/kernel/git/clrkwllms/rt-tests.git"
+SECTION = "tests"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+RDEPENDS = "python python-subprocess python-textutils"
+RRECOMMENDS_${PN} = "kernel-module-hwlat-detector"
+
+require rt-tests.inc
+
+PR = "${INC_PR}.0"
+
+EXTRA_OEMAKE += "PYLIB=${libdir}/python${PYTHON_BASEVERSION}/dist-packages"
+
+do_compile() {
+ oe_runmake hwlatdetect
+}
+
+do_install() {
+ oe_runmake install_hwlatdetect DESTDIR=${D} SBINDIR=${sbindir} \
+ MANDIR=${mandir} INCLUDEDIR=${includedir}
+}
+
+FILES_${PN} += "${libdir}/python${PYTHON_BASEVERSION}/dist-packages/hwlatdetect.py"