summaryrefslogtreecommitdiffstats
path: root/meta/recipes-qt/qt5/qttools_git.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2018-04-27 13:37:25 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2019-03-24 11:13:28 +0100
commit40f1b73c92731f4e18751d3a499f269c65c21a96 (patch)
tree734faeca0e9ccade77c66f04320bf50071ecbf6b /meta/recipes-qt/qt5/qttools_git.bb
parente45f3d305e25ff2aef9e42697e583e6f69a9b6e6 (diff)
downloadopenembedded-core-contrib-40f1b73c92731f4e18751d3a499f269c65c21a96.tar.gz
qt5: downgrade to 5.6jansa/pseudo
* webosose isn't compatible with newer Qt export COMP=qml-webos-framework; for i in `seq -w 1 999`; do echo $i; bitbake -v -v -DDDD -f -c compile ${COMP} 2>${COMP}-logerr.$i >${COMP}-log.$i; bitbake -v -v -DDDD -f -c package_qa ${COMP} 2>${COMP}-logerr.qa.$i >${COMP}-log.qa.$i || { cp -ra tmp-glibc/work/qemux86-oe-linux/${COMP}/ ${COMP}-workdir-$i; bitbake -c cleansstate ${COMP} ; } done in local.conf I have only this to reproduce the failures: PRSERV_HOST = "localhost:0" BB_NUMBER_THREADS = "8" PARALLEL_MAKE = "-j 32" DISTRO_FEATURES_append = " wayland opengl" ERROR_QA_append = " host-user-contaminated" Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta/recipes-qt/qt5/qttools_git.bb')
-rw-r--r--meta/recipes-qt/qt5/qttools_git.bb35
1 files changed, 16 insertions, 19 deletions
diff --git a/meta/recipes-qt/qt5/qttools_git.bb b/meta/recipes-qt/qt5/qttools_git.bb
index df15d88b11..1c8be91f4e 100644
--- a/meta/recipes-qt/qt5/qttools_git.bb
+++ b/meta/recipes-qt/qt5/qttools_git.bb
@@ -1,41 +1,38 @@
require qt5.inc
require qt5-git.inc
-require qt5-ptest.inc
-HOMEPAGE = "http://www.qt.io"
-LICENSE = "GFDL-1.3 & BSD & ( GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial ) & ( GPL-2.0+ | LGPL-3.0 | The-Qt-Company-Commercial )"
+LICENSE = "GFDL-1.3 & BSD & (LGPL-2.1 & The-Qt-Company-Qt-LGPL-Exception-1.1 | LGPL-3.0)"
LIC_FILES_CHKSUM = " \
- file://LICENSE.LGPL3;md5=e6a600fd5e1d9cbde2d983680233ad02 \
- file://LICENSE.GPL2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
- file://LICENSE.GPL3;md5=d32239bcb673463ab874e80d47fae504 \
- file://LICENSE.GPL3-EXCEPT;md5=763d8c535a234d9a3fb682c7ecb6c073 \
+ file://LICENSE.LGPLv21;md5=fb91571854638f10b2e5f36562661a5a \
+ file://LICENSE.LGPLv3;md5=a909b94c1c9674b2aa15ff03a86f518a \
+ file://LICENSE.GPLv3;md5=bfdd8aa675169432d6d9b63d056de148 \
+ file://LGPL_EXCEPTION.txt;md5=9625233da42f9e0ce9d63651a9d97654 \
file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
"
DEPENDS += "qtbase qtdeclarative qtxmlpatterns"
-# Patches from https://github.com/meta-qt5/qttools/commits/b5.10
-# 5.10.meta-qt5.2
+# Patches from https://github.com/meta-qt5/qttools/commits/b5.6
+# 5.6.meta-qt5.1
SRC_URI += " \
- file://0001-add-noqtwebkit-configuration.patch \
- file://0002-linguist-tools-cmake-allow-overriding-the-location-f.patch \
+ file://0001-Allow-to-build-only-lrelease-lupdate-lconvert.patch \
+ file://0002-assistant-help-fix-linking-of-dependent-libraries.patch \
+ file://0003-add-noqtwebkit-configuration.patch \
+ file://0004-linguist-tools-cmake-allow-overriding-the-location-f.patch \
"
FILES_${PN}-tools += "${datadir}${QT_DIR_NAME}/phrasebooks"
FILES_${PN}-examples = "${datadir}${QT_DIR_NAME}/examples"
PACKAGECONFIG ??= ""
+PACKAGECONFIG_class-native ??= "linguistonly"
+PACKAGECONFIG_class-nativesdk ??= "linguistonly"
+PACKAGECONFIG[linguistonly] = ""
PACKAGECONFIG[qtwebkit] = ",,qtwebkit"
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtwebkit', '', 'CONFIG+=noqtwebkit', d)}"
+EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'linguistonly', 'CONFIG+=linguistonly', '', d)}"
-SRCREV = "03ebf1c3d6ceae715c696a171920a0204c58dd0a"
+SRCREV = "56dbabb7a64a4d416e8cf7b61e068208fd032355"
BBCLASSEXTEND = "native nativesdk"
-
-do_install_ptest() {
- mkdir -p ${D}${PTEST_PATH}
- t=${D}${PTEST_PATH}
- cp ${B}/tests/auto/qtdiag/tst_tdiag $t
- cp ${B}/tests/auto/qtattributionsscanner/tst_qtattributionsscanner $t
-}