summaryrefslogtreecommitdiffstats
path: root/meta/recipes-qt/qt5/qtquick1_git.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2018-04-25 21:03:54 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2019-03-24 11:13:28 +0100
commitc44fc9b620f762ce68441f834e1a157288a488e6 (patch)
tree6d6c8d22c68c02b30e5f9240fa8fe84015e3586d /meta/recipes-qt/qt5/qtquick1_git.bb
parentc639a01c7a3ecf1a127fa43fa780fd6328c1367e (diff)
downloadopenembedded-core-contrib-c44fc9b620f762ce68441f834e1a157288a488e6.tar.gz
qt5: import recipes which often reproduce Yocto #12434 from meta-qt5
* just temporary to make it easier to reproduce, import big part of meta-qt5 * qtquickcontrols-5.9.5+gitAUTOINC+75e9561d4f-r0 do_package_qa: QA Issue: qtquickcontrols: /qtquickcontrols-qmlplugins/usr/lib/qml/QtQuick/Controls/Styles/Base/TreeViewStyle.qml is owned by uid 1101, which is the same as the user running bitbake. This may be due to host contamination [host-user-contaminated] * to reproduce this you can try to use something like this: export COMP=qtquickcontrols; for i in `seq -w 1 999`; do echo $i; bitbake -v -v -DDDD -f -c package ${COMP} 2>${COMP}-logerr.$i >${COMP}-log.$i; bitbake -v -v -DDDD -f -c package_qa ${COMP} 2>${COMP}-logerr.qa.$i >${COMP}-log.qa.$i || { cp -ra BUILD/work/i586-oe-linux/${COMP}/ ${COMP}-workdir-$i; bitbake -c cleansstate ${COMP} ; } done Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta/recipes-qt/qt5/qtquick1_git.bb')
-rw-r--r--meta/recipes-qt/qt5/qtquick1_git.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-qt/qt5/qtquick1_git.bb b/meta/recipes-qt/qt5/qtquick1_git.bb
new file mode 100644
index 0000000000..85b8462931
--- /dev/null
+++ b/meta/recipes-qt/qt5/qtquick1_git.bb
@@ -0,0 +1,29 @@
+require qt5.inc
+require qt5-git.inc
+require qt5-ptest.inc
+
+HOMEPAGE = "http://www.qt.io"
+LICENSE = "GFDL-1.3 & BSD & ( GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial ) & ( GPL-2.0+ | LGPL-3.0 | The-Qt-Company-Commercial )"
+LIC_FILES_CHKSUM = " \
+ file://LICENSE.LGPLv21;md5=4bfd28363f541b10d9f024181b8df516 \
+ file://LICENSE.LGPLv3;md5=e0459b45c5c4840b353141a8bbed91f0 \
+ file://LICENSE.GPLv2;md5=c96076271561b0e3785dad260634eaa8 \
+ file://LGPL_EXCEPTION.txt;md5=9625233da42f9e0ce9d63651a9d97654 \
+ file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
+"
+
+DEPENDS += "qtscript qtsvg qtxmlpatterns"
+# qttools
+
+PACKAGECONFIG ??= "webkit"
+PACKAGECONFIG[webkit] = ",,qtwebkit"
+
+EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'webkit', '', 'CONFIG+=noqtwebkit', d)}"
+
+do_configure_prepend() {
+ sed -i 's#^qtHaveModule(webkitwidgets):#qtHaveModule(webkitwidgets):!contains(CONFIG, noqtwebkit):#g' ${S}/src/imports/imports.pro
+}
+
+QT_MODULE_BRANCH = "dev"
+
+SRCREV = "b2476dcd53f0dea1e9eb38df5add3a771d64c4a1"